Bug 1027564 - TestCaseRunStatus cached in a non thread-safe way
TestCaseRunStatus cached in a non thread-safe way
Status: CLOSED NOTABUG
Product: TCMS
Classification: Other
Component: Application (Show other bugs)
3.8.5
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Yang Ren
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 01:13 EST by Chaobin Tang
Modified: 2014-10-19 22:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-19 22:18:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chaobin Tang 2013-11-07 01:13:21 EST
Description of problem:

In 3.8.5, as a quick solution to the performance headache in aggregating the progress for one testrun, the case_run_status is cached using a class level dictionary which basically is a global variable. In a shared-nothing environment such as Apache WSGI, this is a thread-unsage. Because in one process, this dictionary gets outdated, it doesn't in other running processes.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Need to change it to a thread-safe way. Possible solution might be to utilize a robust caching backend, such as memcached or better redis.
Comment 1 cqi 2013-11-17 22:52:26 EST
Related to 1027589
Comment 4 fhuang 2014-10-19 22:18:34 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=1027589 has been modified.

Note You need to log in before you can comment on or make changes to this bug.