Bug 1027573 - FedUp does not switch to other mirror if the mirror for vmlinuz is down or is slowly
FedUp does not switch to other mirror if the mirror for vmlinuz is down or is...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 01:43 EST by Nix\
Modified: 2013-12-22 00:35 EST (History)
4 users (show)

See Also:
Fixed In Version: fedup-0.8.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 02:23:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nix\ 2013-11-07 01:43:19 EST
Description of problem:

Yum generally, using fastestmirror or not, if the mirror of a repo is down, change to other online.
FedUp actually no change/switch to a good speed and online mirror if the mirror for vmlinuz, the first step is down or is slowly.
The only way is using --instrepo=, because if the mirror of the mirrorlist is slowly (like darsat.com.ar) FedUp exit and show that the X bytes in X time, so is a slow connection, etc.

Version-Release number of selected component (if applicable):
Fedora 18 64 bit, fedup-0.7.3-4.fc18

How reproducible:
Always

Steps to Reproduce:
1.Install a Fedora 18 desktop
2.yum update -y
3.fedup-cli --network 19

Actual results:
If the mirror of the list of mirrorlist, more nearest is slowly or down, fedup exit and no switch to other mirror. The only way for skip this problem is using --instrepo= with the master server of Fedora Project.

Expected results:

Add to FedUp the same feature that yum for change of repo when the repo is slowly or down, and no exit.

Additional info:

Actually my box is using F19 because i used --instrepo=dl.fedora etc.
I know that is very dificult reproduce this bug because is necessary a failed/slowly mirror in the mirrorlist for the country. In my case mirrors.dcarsat.com.ar because i live in Argentina.
Comment 1 Will Woods 2013-12-06 17:01:45 EST
fedup-0.8.0 should correctly switch mirrors if it hits a slow/bad mirror for vmlinuz - the same way yum handles slow/bad mirrors.
Comment 2 Fedora Update System 2013-12-11 17:13:02 EST
fedup-0.8.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc19
Comment 3 Fedora Update System 2013-12-11 17:21:09 EST
fedup-0.8.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc20
Comment 4 Fedora Update System 2013-12-11 17:22:59 EST
fedup-0.8.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc18
Comment 5 Fedora Update System 2013-12-13 00:10:32 EST
Package fedup-0.8.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-0.8.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23316/fedup-0.8.0-3.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-12-19 02:23:01 EST
fedup-0.8.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-12-19 20:45:12 EST
fedup-0.8.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-12-22 00:35:22 EST
fedup-0.8.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.