Bug 1027617 - ypbind fails to start before ypserv is started
ypbind fails to start before ypserv is started
Status: CLOSED DUPLICATE of bug 1011507
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ypbind (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Honza Horak
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 03:39 EST by Albert Flügel
Modified: 2013-11-07 05:18 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 05:18:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Flügel 2013-11-07 03:39:38 EST
Description of problem:
The init script of ypbind starts before ypserv. If the same host is
the only available NIS server, ypbind is killed again, before
ypserv is started, what works without problem. This problem arises,
when for instance
* the host itself is the only available NIS server e.g. because
  others are not available e.g. not (yet) up e.g. when all NIS
  servers are booting at the same time
* the host should be the only NIS server for itself (standalone
  configuration while nameservice data updates)

Version-Release number of selected component (if applicable):
ypbind-1.20.4-30.el6.x86_64
ypserv-2.19-26.el6.x86_64


How reproducible:
On a NIS server, only add the same host or localhost in
/etc/yp.conf and reboot. ypbind will fail to start (the init
script checks, whether the NIS service is bound and timeouts
after several attempts and kills ypbind), because ypserv is
not yet available. ypserv will happily start later.

Steps to Reproduce:
1. Set up a working NIS server, assume domain name "localdomain"
2. make this the first line in /etc/yp.conf: domain localdomain server localhost
3. reboot

Actual results:
NIS not bound, no nameservice data from NIS available

Expected results:
NIS is bound, the local ypserv is queried, nameservice data from NIS available

Additional info:
ypbind is started in /etc/rc5.d/S24ypbind ,
ypserv in /etc/rc5.d/S26ypserv . I changed that to
/etc/rc5.d/S25ypbind and /etc/rc5.d/S24ypserv and
it works for me, though i do not consider this a
clean solution. ypserv should start after network
i.e. S24 . ypbind should start after ypserv i.e. S25
but other programs started in S24 and S25 might already
need nameservice data from NIS, so everything in S24
should move up at least by 2 and all stuff above likewise.
Comment 2 Honza Horak 2013-11-07 05:18:44 EST
Thanks for reporting, this bug is actually fixed by build ypserv-2.19-26.el6_4.1, which is already shipped in RHEL-6.4.z.

*** This bug has been marked as a duplicate of bug 1011507 ***

Note You need to log in before you can comment on or make changes to this bug.