Bug 102762 - SysV init script does not allow MIB search path override
SysV init script does not allow MIB search path override
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: net-snmp (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-20 15:12 EDT by thalakan
Modified: 2015-03-04 20:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-19 09:07:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description thalakan 2003-08-20 15:12:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
The SysV init script for snmptrapd does not allow the user to override the 
default MIB search path nor the list of MIB filenames.  In order to have 
snmptrapd report the fully qualified trap names for some equipment, I have to 
load vendor-supplied MIBs, and the only way to have the SysV init system start 
snmptrapd with the correct MIBs is to modify the SysV init script directly.  
This triggers change management procedures unnecessarily at my site (because 
rpm -V no longer reports the package's files as "unchanged") and will cause the 
init script to be overwritten if the package is upgraded.

It seems to me that there should be a /etc/default/snmptrapd file with 
variables to be read in by the SysV init script prior to starting snmptrapd so 
that the options can be set by the user in a rpm %config file.


Version-Release number of selected component (if applicable):
net-snmp-5.0.6-17

How reproducible:
Always

Steps to Reproduce:
1. Modify the SysV init script to load the right MIBs
2. Bitch because you have to log and justify the changes
3. Bitch again when you do an OS upgrade because you have to redo the changes 
from scratch
    

Additional info:
Comment 1 Phil Knirsch 2003-11-19 09:07:59 EST
Thats actually really a good idea.

The latest net-snmp-5.1-1 will now check for the file

/etc/snmp/snmptrapd.options

and source that from the snmptrapd SysV init script, just as you
suggested. This should allow you to select the correct path and mibs
to use.

New package should hit rawhide in the next few days.

Read ya, Phil
Comment 2 Curtis Doty 2004-12-05 01:02:06 EST
How exactly can stuff in snmptrapd.options be passed to snmptrapd?

Maybe you meant to use this
OPTIONS=${OPTIONS--Lsd -p /var/run/snmptrapd.pid}
instead of this?
OPTIONS="-Lsd -p /var/run/snmptrapd.pid"

For me at least, this change is still required to make snmptrapd
actually perform as suggested.

Note You need to log in before you can comment on or make changes to this bug.