Bug 1027621 - Packages have unresolved dependencies
Packages have unresolved dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-phpmd-PHP-PMD (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Christof Damian
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 03:43 EST by Victor Ion Munteanu
Modified: 2013-11-24 18:46 EST (History)
2 users (show)

See Also:
Fixed In Version: php-phpmd-PHP-PMD-1.5.0-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-24 18:46:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Victor Ion Munteanu 2013-11-07 03:43:58 EST
Description of problem:
Can not update php-phpmd-PHP-PMD.noarch and php-pdepend-PHP-Depend.noarch because of missing dependencies

Version-Release number of selected component (if applicable):
php-phpmd-PHP-PMD.noarch 0:1.4.1-2.fc19 
php-pdepend-PHP-Depend.noarch 0:1.1.0-3.fc19

How reproducible:
Always

Steps to Reproduce:
1. yum update
2.
3.

Actual results:
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package php-pdepend-PHP-Depend.noarch 0:1.1.0-3.fc19 will be updated
---> Package php-pdepend-PHP-Depend.noarch 0:1.1.1-2.fc19 will be an update
---> Package php-phpmd-PHP-PMD.noarch 0:1.4.1-2.fc19 will be updated
---> Package php-phpmd-PHP-PMD.noarch 0:1.5.0-1.fc19 will be an update
--> Processing Dependency: php-language >= 5.2.3 for package: php-phpmd-PHP-PMD-1.5.0-1.fc19.noarch
--> Finished Dependency Resolution
Error: Package: php-phpmd-PHP-PMD-1.5.0-1.fc19.noarch (updates)
           Requires: php-language >= 5.2.3
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



Expected results:
The update would be made

Additional info:
It's been going on for some time now, I've used --skip-broken as workaround but it's started to bug me that it doesn't work.

Also the php version satisfies the requirements:
PHP 5.5.5 (cli) (built: Oct 17 2013 06:05:14) 
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2013 Zend Technologies
    with Xdebug v2.2.3, Copyright (c) 2002-2013, by Derick Rethans
Comment 1 Fedora Update System 2013-11-16 14:22:40 EST
php-phpmd-PHP-PMD-1.5.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/php-phpmd-PHP-PMD-1.5.0-2.fc19
Comment 2 Fedora Update System 2013-11-17 02:05:42 EST
Package php-phpmd-PHP-PMD-1.5.0-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-phpmd-PHP-PMD-1.5.0-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21562/php-phpmd-PHP-PMD-1.5.0-2.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-11-24 18:46:05 EST
php-phpmd-PHP-PMD-1.5.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.