Bug 1027672 - Missing SELINUX boolean description in the documentation
Missing SELINUX boolean description in the documentation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-SELinux_Managing_Confined_Services_Guide (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Capek
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 04:27 EST by pierre.casenove
Modified: 2013-12-04 05:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-04 05:30:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pierre.casenove 2013-11-07 04:27:48 EST
Description of problem:
The following SELINUX booleans applicable to httpd daemon are not documented in the "Managing Confined service" documentation:
httpd_use_openstack
httpd_tmp_exec
httpd_setrlimit
httpd_read_user_content
httpd_manage_ipa
httpd_can_network_memcache
httpd_can_network_connect_cobbler
httpd_can_check_spam
httpd_use_gpg


Version-Release number of selected component (if applicable): 6.4


How reproducible: Not Applicable


Steps to Reproduce:
Not applicable

Actual results:


Expected results:


Additional info:
Comment 2 Tomas Capek 2013-11-26 07:54:45 EST
Due to the continuous development of the SELinux policy, the list of documented Booleans might not contain all of them at all times. To list them all, run the following command as root: 

semanage boolean -l | grep httpd


With the current release of the book, all services now contain this admonition to account for any Booleans that might be missing in the text:

https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html-single/Managing_Confined_Services/index.html#sect-Managing_Confined_Services-The_Apache_HTTP_Server-Booleans

Note You need to log in before you can comment on or make changes to this bug.