Bug 1027688 - gnome-software dont pickup installed package before system is rebooted.
gnome-software dont pickup installed package before system is rebooted.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 04:49 EST by Tim Lauridsen
Modified: 2014-08-07 11:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-07 11:28:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
before reboot (126.71 KB, image/png)
2013-11-07 04:49 EST, Tim Lauridsen
no flags Details
after reboot (143.02 KB, image/png)
2013-11-07 04:50 EST, Tim Lauridsen
no flags Details
after remove, and search for yumex (159.21 KB, image/png)
2013-11-07 04:52 EST, Tim Lauridsen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 734437 None None None Never

  None (edit)
Description Tim Lauridsen 2013-11-07 04:49:31 EST
Created attachment 820968 [details]
before reboot

Description of problem:
If I install a local package with a newer version of an application, gnome-software don't pickup the change before the system is changed.


Version-Release number of selected component (if applicable):
3.11.1


How reproducible:
every time


Steps to Reproduce:
1. git clone https://github.com/timlau/yumex.git
2. cd yumex
3. sudo make get-builddeps
4. make test-inst (this will build & install a local 3.0.14 yumex package)
5. start gnome-software
6. search for 'yumex'

Actual results:
gnome-software shows the yumex-3.0.13 package available in the repository

Expected results:
gnome-software shows the yumex-3.0.14 package installed on the system.

Additional info:
After reboot of the system, then yumex-3.0.14 is shown with the appdata infomation it contains.
If I remove the yumex-3.0.14 package using gnome-software and seach for yumex, it finds the yumex-3.0.14 package as available, if I tries to install it, gnome-software will crach because the yumex-3.0.14 package is not available from the repository to install.
Comment 1 Tim Lauridsen 2013-11-07 04:50:39 EST
Created attachment 820969 [details]
after reboot
Comment 2 Tim Lauridsen 2013-11-07 04:52:15 EST
Created attachment 820970 [details]
after remove, and search for yumex
Comment 3 Adam Williamson 2014-08-07 11:28:37 EDT
Thanks for the report! I spoke to hughsie about this bug and he said the correct way to fix it (and several similar cases) would be for Software to listen to PackageKit for cache invalidations, and refresh its metadata when that happens. He said it'd make most sense to track this as an upstream bug (as it's basically a 'new feature', even though the purpose is to fix bugs), so I've filed https://bugzilla.gnome.org/show_bug.cgi?id=734437 , and we'll close this in favour of that - it doesn't mean the bug won't be fixed, just that that's the best way to track work. Thanks again!

Note You need to log in before you can comment on or make changes to this bug.