Bug 10277 - Problem with samba printing
Problem with samba printing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-20 20:26 EST by mal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-27 11:18:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mal 2000-03-20 20:26:34 EST
I have a HPLJ4 printer connetcted to Linux.
This printer is configured with PS filter
via ghostcript and all programs print
PostScript to this printer.
Everything works fine when printing PostScript from Linux.
This printer is also shared via samba
to windows network.

The problem is:
when printing PostScript from Windows via samba
something does not recognize that this is PostScript
and I see just PostScript text printed.
GhostScript either not called or does not recognize that this is
PostScript.
In the same time when
I save PostScript output of windows program to a file tmp.ps
and then give
lpr tmp.ps
command on Linux the file is printed OK,
ghostscript successfully converts PS to HP printer PCL.
Comment 1 Nalin Dahyabhai 2000-03-21 07:50:59 EST
Do you have "postscript = true" set in the relevant section of your
/etc/smb.conf configuration file?
Comment 2 mal 2000-03-23 15:14:59 EST
I tried postscript=true option.
It works with it, but this option
requires one to put every printer to smb.conf
I can not just export all printers as it was before,
because postscript=true option screws up non-PostScript
printing when set globally.

In general case it may be better to configure
samba automatically set this option
if specific printer is known to be PostScript printer.
Comment 3 Bill Nottingham 2000-07-15 14:49:08 EDT
I'm closing this, as it seems to be more of a configuration issue
than a samba bug.

Note You need to log in before you can comment on or make changes to this bug.