Bug 1027703 - KDE Task manager widget not removing all closed windows
KDE Task manager widget not removing all closed windows
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kdebase-workspace (Show other bugs)
6.6
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
: ZStream
Depends On:
Blocks: 1232259
  Show dependency treegraph
 
Reported: 2013-11-07 05:14 EST by Ben
Modified: 2015-10-22 05:32 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, windows and application closed in the K desktop environment (KDE) in some cases remained in the KDE task manager widget. This update modifies the behavior of the task manager, and closed windows and applications are now reliably removed from the widget.
Story Points: ---
Clone Of:
: 1232259 (view as bug list)
Environment:
Last Closed: 2015-10-22 05:32:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Task Manager patch (11.30 KB, patch)
2014-11-11 00:40 EST, Bob Farmer
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 202199 None None None Never
Red Hat Knowledge Base (Solution) 1392893 None None None Never

  None (edit)
Description Ben 2013-11-07 05:14:36 EST
Description of problem:
Now and again (I've been unable to work out which windows/applications are affected) a window/application closed on the KDE desktop will not be removed from the KDE task manager widget.  Clicking on them does not raise the window/application that they represented, nor does right clicking and selecting "close" get rid of them.  The only way to get rid of them is to remove the task manager widget and re-add it.  At which point only current windows/applications appear.

Version-Release number of selected component (if applicable):
Task Manager widget v1.0
KDE 3.4.3 (RHEL6)

How reproducible:
It seems to be random, but I wouldn't swear that it's not just specific windows, or ones closed in a specific way.

Steps to Reproduce:
1. Open windows/applications
2. Close them, or have them go away for some reason
3. Observe them on the task manager.  Sometimes they retain their application-specific icon, sometimes they get the generic X.org icon.

Actual results:
Entries hang around in task manager even after they don't need to.

Expected results:
Entries vanish.  Task manager only shows extant tasks.

Additional info:
Happy to provide any.
Comment 2 Bob Farmer 2014-11-11 00:26:11 EST
Easily reproduceable on RHEL 6.5 or 6.6:
(1) Login to a fresh KDE session.
(2) Bringing up the properties of the Task Manager, then check the box for "Only show tasks from the current desktop".
(3) Open a Konsole window.  Right-click its title bar and set it to show on "All Desktops". 
(4) Switch to a different desktop, and on this new desktop, close that Konsole window by hitting the "X" in the upper right.
(6) Switch back to your previous desktop and there will now be a ghost Konsole entry stuck in your taskbar forever there.

The bug is this: https://bugs.kde.org/show_bug.cgi?id=202199
And is fixed in KDE checkin r1063320, as mentioned in the KDE bug ticket.

To test, I took the patch from r1063320, applied it to RHEL6.6's kde-workspace SRPM, rebuilt RPMs, and the problem is fixed.
Comment 3 Bob Farmer 2014-11-11 00:29:36 EST
Sorry, that should read "kdebase-workspace", not "kde-workspace".
Comment 4 Bob Farmer 2014-11-11 00:40:04 EST
Created attachment 956102 [details]
Task Manager patch

This is the patch from KDE checkin r1063320, for kdebase-workspace-4.3.4-28.el6_5.
Comment 5 Ngo Than 2014-11-11 10:19:37 EST
(In reply to Bob Farmer from comment #2)
> Easily reproduceable on RHEL 6.5 or 6.6:
> (1) Login to a fresh KDE session.
> (2) Bringing up the properties of the Task Manager, then check the box for
> "Only show tasks from the current desktop".
> (3) Open a Konsole window.  Right-click its title bar and set it to show on
> "All Desktops". 
> (4) Switch to a different desktop, and on this new desktop, close that
> Konsole window by hitting the "X" in the upper right.
> (6) Switch back to your previous desktop and there will now be a ghost
> Konsole entry stuck in your taskbar forever there.
> 
> The bug is this: https://bugs.kde.org/show_bug.cgi?id=202199
> And is fixed in KDE checkin r1063320, as mentioned in the KDE bug ticket.
> 
> To test, I took the patch from r1063320, applied it to RHEL6.6's
> kde-workspace SRPM, rebuilt RPMs, and the problem is fixed.

Bob, i have tried your steps to reproduce this issue but without success.
It seems it's not always reproduceable with your steps!
Could you please provive more infos?

Thanks
Comment 6 Bob Farmer 2014-11-12 02:37:48 EST
I re-tested with a freshly installed RHEL6.6 system and newly-created user account, and had no problem reproducing it.  Here's exactly what I did, and I'll try to be a little more precise.

(1) Install 64-bit RHEL Workstation 6.6 from RH's DVD, adding the "KDE Desktop" package set of course.  Defaults for everything else.
(2) Login as the user that you created during the install, with a KDE session.
(3) Right-click on the Task Manager, bring up the Settings, check the box that reads "Only show tasks from the current desktop".  Hit OK to save.
(4) Right-click on the empty desktop and bring up a Konsole window.
(5) Right-click on Konsole's title bar and set it to show on "All Desktops".
(6) Switch to Desktop 2.
(7) Click on the "X" at the upper right of the Konsole window to close it.
(8) Switch back to Desktop 1.
(9) You should now see the Konsole ghost entry stuck in your taskbar.

I'm sure the problem occurs in multiple situations, but this is the most straightforward way we've found to reproduce it.
Comment 7 Bob Farmer 2014-11-12 02:43:51 EST
By the way, if you tried testing on your normal user account, some of your other Task Manager options may have influenced the behavior.  Only certain combinations of settings cause the problem.  That's why I suggested a fresh session/user.
Comment 8 Ben 2014-11-20 12:21:13 EST
Just as a data point, it's not just Konsole windows that do it.  I regularly get Red Hat-packaged Firefox window entries hanging around, too.  Likewise some Skype ones.  And this is without trying to send the windows to other desktops.

I continue to 'fix' it by removing and readding the Task Manager widget.  But that's been getting old for quite a while now!  Any chance of the patch being folder in some time soon, please?
Comment 9 Ben 2015-01-23 11:51:09 EST
Just a nudge that this is still happening and I'm having to remove and re-add the Task Manager applet at least two or three times a day to ensure only live windows are shown.
Comment 10 Bob Farmer 2015-01-23 20:06:50 EST
We've been running with the patch I mentioned earlier for about 3 months now, and the problem hasn't re-occurred for our users.
Comment 11 Ben 2015-01-26 04:41:31 EST
I don't suppose you could let me have a copy of your most recently rolled kdebase-workspace RPM, could you please? (-:
Comment 12 Ngo Than 2015-01-26 09:51:11 EST
Ben, Bob
i have built new packages with the fix and uploaded to
https://than.fedorapeople.org/rhel6/

Could you please download it and confirm that the new package fixes the issue?

Thanks.

Than
Comment 13 Ben 2015-01-26 09:56:33 EST
If you roll some i686 ones then I'll do it immediately! (-:

Ben
Comment 14 Ngo Than 2015-01-26 10:11:28 EST
Ben, i even uploaded the i688 rpms. Please try again :)
Comment 15 Ben 2015-01-26 10:21:34 EST
Excellent!  Thank you.  Give me a few days to try them out and I'll post my results.  Hopefully by the end of the working day 2015-01-28 (GMT).  Potentially by end of the working day 2015-01-27.

Ben
Comment 16 Ben 2015-01-27 12:09:00 EST
OK, thus far everything seems to be looking pretty good.  I'll give it another 24 hours of use and then say that this has, indeed, quashed the bug!
Comment 17 Ben 2015-01-28 09:21:28 EST
Happy to confirm that I've had no ghost entries remaining in my task manager applet since the installation of those RPMs and a restart of KDE.  Definitely a good fix.  Hope to see it as an official errata soon.

Thanks to both of you!

Ben
Comment 18 Ngo Than 2015-01-28 10:21:47 EST
Ben, many thanks for your testing and veryfing the fix!
and Bob, thanks for the the patch.
Comment 19 Ben 2015-01-29 10:34:44 EST
One thing I have noticed since installing these RPMs is that the KDE Pager widget now doesn't highlight the desktop I'm on when I change from one to another with shortcut keys.  It does if I click on the desktop I want to change to, but if I use keyboard shortcuts (currently using CTRL+arrow keys) it usually doesn't make the one I move to 'glow' any more.  _Sometimes_ it'll move the 'glow' to another desktop if I move through a few, but it usually never stops on the desktop I've stopped on.

This didn't happen until I installed your RPMs.
Comment 20 Ben 2015-02-27 04:20:42 EST
OK, it appears that the behaviour I was seeing and mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1027703#c19 (Comment 19) have stopped.  I don't know what the issue was, but it has gone.
Comment 21 Bob Farmer 2015-03-14 07:17:45 EDT
(In reply to Ben from comment #20)
> OK, it appears that the behaviour I was seeing and mentioned in
> https://bugzilla.redhat.com/show_bug.cgi?id=1027703#c19 (Comment 19) have
> stopped.  I don't know what the issue was, but it has gone.

Not seeing that problem here with the patch I posted, either.  Based on the changes in the patch, I wouldn't think it could be related.
Comment 23 Ben 2015-03-25 12:27:07 EDT
Any chance you can make that visible to us plebs, please?

https://access.redhat.com/solutions/1392893 says access denied.
Comment 24 Ron van der Wees 2015-03-26 04:24:05 EDT
(In reply to Ben from comment #23)
> Any chance you can make that visible to us plebs, please?
> 
> https://access.redhat.com/solutions/1392893 says access denied.
Not yet, its being worked on. This solution article is just a replay of
the information found here or in the upstream ticking but no new
information.
Once completed I will make it viewable for customers.

Note You need to log in before you can comment on or make changes to this bug.