Bug 1027732 - Uncaught exception when showing bundle deployment status when deploying to an empty group
Uncaught exception when showing bundle deployment status when deploying to an...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Provisioning (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity unspecified
: ER07
: JON 3.2.0
Assigned To: John Mazzitelli
Mike Foley
:
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-11-07 05:47 EST by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:35:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-11-07 05:47:37 EST
Description of problem:

I cannot check details of bundle deployment, exception pops up in UI

Version-Release number of selected component (if applicable):
JON 3.2.ER5

How reproducible: always


Steps to Reproduce:
1. upload & deploy some bundle
2. explore it's live destination, try to look on status of deployment on agents

Actual results:
com.google.gwt.core.client.JavaScriptException:(TypeError) 
 stack: TypeError: Cannot read property 'category' of null
    at $addMemberDeploymentsTable (<anonymous>:43487:75)
    at $viewBundleDeployment (<anonymous>:43634:3)
    at $onSuccess_178 (<anonymous>:43893:3)

Expected results: you can see deployment status and details for all agents in given destination


Additional info: this regressed since ER4
Comment 1 John Mazzitelli 2013-11-07 07:56:05 EST
this is strange, I know I tried this just a couple days ago when I committed some bundle fixes. Can you post what your browser URL is so I know exactly what page this is?
Comment 2 John Mazzitelli 2013-11-07 08:20:39 EST
http://xxx:7080/coregui/#Bundles/Bundle/10051/deployments/10032

columnNumber: 2: this$static.deployment.destination.group.resourceType is null
   at Unknown.$addMemberDeploymentsTable(Unknown Source)
   at Unknown.$viewBundleDeployment(Unknown Source)
   at Unknown.$onSuccess_178(Unknown Source)
   at Unknown.onSuccess_184(Unknown Source)
   at Unknown.$onResponseReceived(Unknown Source)
   at Unknown.onResponseReceived_6(Unknown Source)
   at Unknown.$fireOnResponseReceived(Unknown Source)
   at Unknown.onReadyStateChange_0(Unknown Source)
   at Unknown.this$static.onreadystatechange<(Unknown Source)
Comment 3 John Mazzitelli 2013-11-07 08:26:35 EST
this occurred because the group was empty when the bundle was deployed.

We need to either:

a) fix this NPE (there is no members of the group, so its not a compatible group and thus no resource type associated with it)

or

b) don't allow a user to deploy a bundle to an empty group
Comment 4 Libor Zoubek 2013-11-07 09:04:50 EST
I'd vote for fixing NPE, b) does not prevent this issue, because user can remove members from group after he deployed bundle (this is what happened in my case).
Comment 5 John Mazzitelli 2013-11-07 10:03:48 EST
git commit to master: e39a3be5c0bfbc7da0cff69c42af09da235807b1
git commit to release/jon3.2.x: 345747659010cddeb59874f18d4e0f14260aa287
Comment 7 Libor Zoubek 2013-11-25 03:42:16 EST
verified on ER7

Note You need to log in before you can comment on or make changes to this bug.