Bug 1027739 - Broker failing to communicate with nodes via qpid
Broker failing to communicate with nodes via qpid
Status: CLOSED DEFERRED
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Troy Dawson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 06:03 EST by Myroslav Opyr
Modified: 2015-05-14 22:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-03 13:57:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
qpidd log at info+ level (6.21 KB, text/x-log)
2013-11-07 06:03 EST, Myroslav Opyr
no flags Details
mcollective node log at debug level (8.72 KB, text/plain)
2013-11-07 06:04 EST, Myroslav Opyr
no flags Details
mcollective client log at debug level while running "mco ping" (6.64 KB, text/plain)
2013-11-07 06:05 EST, Myroslav Opyr
no flags Details

  None (edit)
Description Myroslav Opyr 2013-11-07 06:03:30 EST
Created attachment 821013 [details]
qpidd log at info+ level

Description of problem:

During oo setup there is messaging component testing with "mco ping" It fails:

# mco ping

---- ping statistics ----
No responses received

OO Broker is not able to communicate with nodes in this state.

Version-Release number of selected component (if applicable):

* broker: qpid-cpp-server-0.24-3.fc19.1.i686
* node: mcollective-2.2.3-1.fc19.noarch mcollective-qpid-plugin-1.3.2-1.fc19.noarch
* mco utility: mcollective-client-2.2.3-1.fc19.noarch


How reproducible:

Always. I've installed the above mentioned software on 2 fresh servers and mco ping cannot discover nodes (neither locally run on same server, nor remotely on separate system).


Steps to Reproduce:
1. Install and run qpid-cpp-server
2. Install configure and run mcollective server with mcollective-qpid-plugin
3. Install and configure mcollective-client
4. Run mco ping

Actual results:

---- ping statistics ----
No responses received


Expected results:

The mcollective server running should be discoverable and pingable when running through qpidd

Additional info:

I've recorded asciicast of the setup process, configuration and up to failing mco ping at http://asciinema.org/a/6272 (8m42s).
Comment 1 Myroslav Opyr 2013-11-07 06:04:47 EST
Created attachment 821014 [details]
mcollective node log at debug level
Comment 2 Myroslav Opyr 2013-11-07 06:05:54 EST
Created attachment 821015 [details]
mcollective client log at debug level while running "mco ping"
Comment 3 Myroslav Opyr 2013-11-07 06:16:02 EST
FYI, I've been following instructions: http://fedoraproject.org/wiki/OpenShift_Origin-F19#Node:_MCollective and in the end of the section there is "mco ping" command that I got stuck into.
Comment 4 Krishna Raman 2013-12-09 13:08:58 EST
We no longer use QPid since Release 2 of Origin. Latest setup instructions use ActiveMQ. Will look into updating Fedora packages.
Comment 5 Troy Dawson 2014-06-09 15:48:32 EDT
The problem with moving Fedora packages to activemq, from qpid, is that activemq on Fedora doesn't work.  It doesn't have a activemq server, only the plugins.
Comment 6 Troy Dawson 2014-10-03 13:57:41 EDT
The openshift origin broker is no longer supported on Fedora 20+, whether using qpid or activemq.
It is suggested to migrate your openshift project to RHEL/Scientific Linux/CentOS.

Note You need to log in before you can comment on or make changes to this bug.