Bug 1027743 - [Remove-brick] : Committing a brick from CLI does not remove the remove brick icon from the volume activities table.
[Remove-brick] : Committing a brick from CLI does not remove the remove brick...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity high
: ---
: RHGS 2.1.2
Assigned To: Darshan
RamaKasturi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 06:16 EST by RamaKasturi
Modified: 2015-05-13 12:33 EDT (History)
7 users (show)

See Also:
Fixed In Version: cb12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 03:01:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attaching screen shot (191.81 KB, image/png)
2013-11-07 06:16 EST, RamaKasturi
no flags Details
Attaching the screenshot after the fix (185.84 KB, image/png)
2013-12-03 07:56 EST, RamaKasturi
no flags Details
engine logs (7.38 MB, text/x-log)
2013-12-05 01:35 EST, Shruti Sampat
no flags Details
Attaching the screenshot (211.62 KB, image/png)
2013-12-19 00:26 EST, RamaKasturi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21446 None None None Never

  None (edit)
Description RamaKasturi 2013-11-07 06:16:15 EST
Created attachment 821018 [details]
Attaching screen shot

Description of problem:
Committing a brick from CLI does not remove the remove brick icon from the volume activities table.

Version-Release number of selected component (if applicable):

rhsc-2.1.2-0.22.master.el6_4.noarch
How reproducible:
Always

Steps to Reproduce:
1. Create a distribute volume with single node cluster.
2. Select one brick and click on remove in the bricks sub tab.
3. Once data migration is over , go to the node and run the following command "
gluster volume remove-brick <volName> <brickName> commit"

Actual results:
It removes the brick and the brick row from the bricks subtab, but does not remove the remove-brick icon from the volume activities column.

Expected results:
it should remove the remove-brick icon from the volume activities column.

Additional info:
Comment 1 RamaKasturi 2013-11-07 06:22:14 EST
Link to the sos reports

http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/rhsc/1027743/
Comment 3 Dusmant 2013-11-09 05:14:27 EST
Considering it's not able to remove the icon from volume table, it's low to medium priority. From Brick table it's removing the brick row anyway...

So, severity should be medium to low.
Comment 4 RamaKasturi 2013-11-12 07:34:05 EST
Remove brick status dialog hangs when clicked on status button from the drop down.
Comment 5 RamaKasturi 2013-11-27 02:06:27 EST
Task pane does not get updated. It just hangs.
Comment 6 RamaKasturi 2013-12-03 07:56:12 EST
Icon in the activities column disappears, but the drop down menu arrow still remains,which is meaningless without the icon.

Tasks pane shows the status of the task as migration complete with a question mark. Attaching the screenshot for the same.

Along with icon the menu should also disappear and the task status should be completed. Moving back to assigned.
Comment 7 RamaKasturi 2013-12-03 07:56:55 EST
Created attachment 832039 [details]
Attaching the screenshot after the fix
Comment 8 Shruti Sampat 2013-12-05 01:32:51 EST
Seeing behavior similar to what is explained in Comment #6 when, a server is added to the cluster while remove-brick is in progress.
Comment 9 Shruti Sampat 2013-12-05 01:35:30 EST
Created attachment 833025 [details]
engine logs
Comment 10 RamaKasturi 2013-12-13 06:25:45 EST
Moving this bug to Failed_QA because of this bug.

https://bugzilla.redhat.com/show_bug.cgi?id=1040959
Comment 11 Sahina Bose 2013-12-17 11:22:06 EST
As bug referenced in Comment 10 is ON_QA, moving this as well
Comment 12 Darshan 2013-12-18 03:39:02 EST
Now, when we commit remove-brick from cli, the task status gets updated to unknown. Because of this the remove brick icon is replaced by '?' icon.
Comment 13 RamaKasturi 2013-12-18 07:03:46 EST
Currently , the behavior for the '?' icon to appear in the volume activities column after a brick has been committed takes around 45-50 seconds.

please let me know if this is the expected result?
Comment 14 Darshan 2013-12-18 07:08:02 EST
yes, this is the expected behaviour. The '?' icon will appear within 1 min (when the syncing happens).
Comment 15 RamaKasturi 2013-12-18 11:43:04 EST
Verified in cb12 rhsc-2.1.2-0.28.beta.el6_5.noarch . The following happens:

when a brick is comitted from cli, brick row disappears from the bricks sub tab and icon in the volume activities column remain unchanged to Migration completed and commit pending, till the sync happens.

Currently , for the '?' icon to appear in the volume activities column after a brick has been committed takes around 45-50 seconds.
Comment 16 RamaKasturi 2013-12-19 00:26:21 EST
Created attachment 838765 [details]
Attaching the screenshot
Comment 17 Darshan 2014-01-03 03:54:15 EST
doc_text not need as it is an intermediate build issue.
Comment 19 errata-xmlrpc 2014-02-25 03:01:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.