Bug 1027765 - Rete tree build error with conditional consequences
Rete tree build error with conditional consequences
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Eclipse Tooling (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ER5
: 6.0.0
Assigned To: Kris Verlaenen
Tomas Schlosser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 06:49 EST by Tomas Schlosser
Modified: 2014-08-06 16:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:19:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker DROOLS-326 Major Resolved Drools plugin Rete Tree viewer does not work with Conditional Named Consequence expressions 2014-01-15 06:32:01 EST

  None (edit)
Description Tomas Schlosser 2013-11-07 06:49:35 EST
Description of problem:
The rete tree can't be built for rules containing conditional consequence.

Version-Release number of selected component (if applicable):
BRMS 6.0.0.ER4
JBDS 7.0.1.GA
Drools plugin 6.0.0.201308222359 (and also master as of 2013-11-07)

Steps to Reproduce:
1. create a rule resource with constraints connected by || operator
2. switch rule editor to "Rete Tree"

Actual results:
Rete Tree Build Error!

Expected results:
Rete tree.

Error log from Eclipse:
java.lang.reflect.InvocationTargetException
	at org.drools.eclipse.editors.DRLRuleEditor2$3.run(DRLRuleEditor2.java:248)
	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
Caused by: org.drools.core.RuntimeDroolsException: java.lang.reflect.InvocationTargetException : [Rete(0)]
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:59)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitReteooRuleBase(ReteooVisitor.java:79)
	at org.drools.eclipse.editors.rete.ReteViewer.loadReteModel(ReteViewer.java:172)
	at org.drools.eclipse.editors.DRLRuleEditor2$3.run(DRLRuleEditor2.java:240)
	... 1 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:50)
	... 4 more
Caused by: org.drools.core.RuntimeDroolsException: java.lang.reflect.InvocationTargetException : [EntryPointNode(1) EntryPoint::DEFAULT ]
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:59)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitRete(ReteooVisitor.java:97)
	... 9 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.GeneratedMethodAccessor64.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:50)
	... 10 more
Caused by: org.drools.core.RuntimeDroolsException: java.lang.reflect.InvocationTargetException : [ObjectTypeNode(5)::EntryPoint::DEFAULT objectType=[ClassObjectType class=com.sample.Message] expiration=-1ms ]
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:59)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitNode(ReteooVisitor.java:154)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitBaseNode(ReteooVisitor.java:135)
	... 14 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.GeneratedMethodAccessor64.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:50)
	... 16 more
Caused by: org.drools.core.RuntimeDroolsException: java.lang.reflect.InvocationTargetException : [LeftInputAdapterNode(6)]
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:59)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitNode(ReteooVisitor.java:154)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitBaseNode(ReteooVisitor.java:135)
	... 20 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.GeneratedMethodAccessor64.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:50)
	... 22 more
Caused by: org.drools.core.RuntimeDroolsException: java.lang.reflect.InvocationTargetException : [ConditionalBranchNode: cond=if ( $msg.text != null ) break[[RuleTerminalNode(7): rule=testNamedConsequence]]]
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:59)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitNode(ReteooVisitor.java:154)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitBaseNode(ReteooVisitor.java:135)
	... 26 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.GeneratedMethodAccessor64.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:50)
	... 28 more
Caused by: java.lang.RuntimeException: problem visiting vertex org.drools.core.reteoo.ConditionalBranchNode
	at org.drools.eclipse.reteoo.ReteooVisitor.visitBaseNode(ReteooVisitor.java:110)
	... 32 more
Caused by: java.lang.ClassNotFoundException: org.drools.eclipse.reteoo.ConditionalBranchNodeVertex cannot be found by org.drools.eclipse_6.0.0.201308222359
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:501)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:190)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitBaseNode(ReteooVisitor.java:107)
	... 32 more
Comment 2 JBoss JIRA Server 2013-11-07 09:07:11 EST
Kris Verlaenen <kris.verlaenen@gmail.com> updated the status of jira DROOLS-326 to Resolved
Comment 3 Tomas Schlosser 2014-01-15 06:32:17 EST
Verified with Drools plugin 6.0.1.Final

Note You need to log in before you can comment on or make changes to this bug.