Bug 1027772 - [RFE] add possibility to reserve memory for VM in a cluster when it is not running
Summary: [RFE] add possibility to reserve memory for VM in a cluster when it is not ru...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact: Shira Maximov
URL:
Whiteboard:
Depends On: 1027697
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-07 11:56 UTC by David Jaša
Modified: 2018-06-26 16:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 16:12:50 UTC
oVirt Team: SLA
ylavi: ovirt-future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description David Jaša 2013-11-07 11:56:38 UTC
Description of problem:
In mixed-use clusters, administrator may want to reserve some resources for important VMs so that they might run anytime, regardless of level of use by less important VMs. The tightest bottleneck IMO is memory so this RFE is centered around this resource. The result should be that if the VM with such reserved memory configured is not running, engine should make sure that there is enough free memory on some host to run the VM (with the catch that if there are more such VMs in the cluster, the free memory on host must align with requirements of VMs - say if there are three VMs with 2 GB reserved each on 2-node cluster with 6 GB of free RAM, the free memory has to be 4 + 2 or 2 + 4 GB, not 3 + 3 GB).

Configuration-wise, there are more possible approaches how to configure this:
  * reserve equivalent of Physical Memory Guaranteed automatically for HA VMs
  * add a checkbox next to Physical Memory Guaranteed that would reserve the same amount when the VM is off
  * add Reserved Memory next to Physical Memory Guaranteed


Version-Release number of selected component (if applicable):
3.3

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Scott Herold 2014-01-13 16:17:32 UTC
We are implementing HA Reservations in 3.4 under BZ 1027697.  We want to implement the HA reservation policy, then look to extend to additional use cases such as reservations for Powered Off VMs.

Comment 2 Martin Sivák 2018-06-26 16:12:50 UTC
It has been years since this was opened and it never spiked any interest. Closing for now. Please reopen with justification if it is important for you.


Note You need to log in before you can comment on or make changes to this bug.