Bug 102780 - df -l stat64's non-local filesystems
df -l stat64's non-local filesystems
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-20 18:02 EDT by Andrei Gaponenko
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-21 08:28:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "strace df -l" (11.38 KB, text/plain)
2003-08-20 18:03 EDT, Andrei Gaponenko
no flags Details

  None (edit)
Description Andrei Gaponenko 2003-08-20 18:02:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030716

Description of problem:

Could not reopen bug 67178, so posting a new one. 

[bug #67178] > This is fixed in 4.1.9-*.

Well, it does not seem to be fixed. At least not in 4.1.9-11.
"df -l" hangs because the /twist/tw14 NFS filesystem in not
accessible.  Below is the /proc/mounts contents, and an output
of "strace -o file df -l" (terminated with Control-C) is attached.
Note that /dev/hdc1 was mounted later than /twist/tw14.

tw10 ~$ cat /proc/mounts 
rootfs / rootfs rw 0 0
/dev/root / ext3 rw 0 0
/proc /proc proc rw 0 0
usbdevfs /proc/bus/usb usbdevfs rw 0 0
/dev/hda3 /data ext3 rw 0 0
none /dev/pts devpts rw 0 0
none /dev/shm tmpfs rw 0 0
automount(pid696) /triumfcs autofs rw 0 0
automount(pid709) /home autofs rw 0 0
automount(pid733) /misc autofs rw 0 0
automount(pid765) /twist autofs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
e614db:/home1/e614data /home/e614data nfs
rw,v3,rsize=4096,wsize=4096,hard,intr,udp,lock,addr=e614db 0 0
dork:/home1/quraan /home/quraan nfs
rw,v3,rsize=4096,wsize=4096,hard,intr,udp,lock,addr=dork 0 0
tw14:/data /twist/tw14 nfs
rw,v3,rsize=4096,wsize=4096,hard,intr,udp,lock,addr=tw14 0 0
/dev/hdc1 /data1 ext3 rw 0 0
dork:/home1/andr /home/andr nfs
rw,v3,rsize=4096,wsize=4096,hard,intr,udp,lock,addr=dork 0 0
lin00:/home/export /triumfcs/linux nfs
ro,v3,rsize=4096,wsize=4096,hard,intr,udp,lock,addr=lin00 0 0


Version-Release number of selected component (if applicable):
fileutils-4.1.9-11

How reproducible:
Always

Steps to Reproduce:
strace df -l when a local filesystem is mounted later than a NFS one.


Actual Results:  df -l hangs on NFS mount

Expected Results:  df -l should never hang

Additional info:
Comment 1 Andrei Gaponenko 2003-08-20 18:03:33 EDT
Created attachment 93805 [details]
output of "strace df -l"
Comment 2 Tim Waugh 2003-08-21 08:14:28 EDT
Please also attach /etc/fstab and /etc/mtab.  Thanks.
Comment 3 Tim Waugh 2003-08-21 08:28:30 EDT
Actually scratch that.

This seems to be a separate issue: automounted filesystems.

I believe this case is fixed in coreutils (in Red Hat Linux 9).  Couldn't
reproduce the problem in coreutils-5.0-13 from rawhide.

Note You need to log in before you can comment on or make changes to this bug.