Bug 102781 - supported/unsupported split prevents reiserfs installs (not reiser specific)
supported/unsupported split prevents reiserfs installs (not reiser specific)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-20 18:10 EDT by Tom "spot" Callaway
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 15:00:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2003-08-20 18:10:17 EDT
As a byproduct of the kernel-unsupported package, it is impossible to perform
installs with filesystem drivers that exist in the -unsupported package.
Specifically, reiserfs is prevented as an option, which it previously was in
RHEL AS 2.1. This is a regression, and several customers testing RHEL 3 Beta 1
have comes across this.

Anaconda still has the requisite code to use Reiserfs on demand (boot with linux
reiserfs), but the module is no longer present in the install environment due to
the split. Reiserfs is especially useful in RHEL 3 because of its resize
capabilities that ext3 does not currently possess.

Suggested Resolution:

Move the filesystem modules back into the kernel "supported" package, or do not
perform the split for kernel-BOOT.
Comment 2 Arjan van de Ven 2003-08-20 18:22:58 EDT
we are absolutely not in a position to support reiserfs.
If reiserfs has online resize that is interesting but we have done zero testing
on the correctness of that... (ext3 has offline resize already)
Comment 3 Tom "spot" Callaway 2003-08-20 18:29:54 EDT
Then by all means, don't support reiserfs. But the installer should let the user
install to reiserfs. Bugs arising from that use can be closed immediately.

My customers are fine with that. All they see is that competing enterprise
distributions aren't "crippled" like this, and in our previous release, this bug
didn't exist.
Comment 4 Tim Burke 2003-09-29 15:00:25 EDT
We do not currently support rieserfs.  For this reason it was moved to
kernel-unsupported in RHEL 3.

Note You need to log in before you can comment on or make changes to this bug.