Bug 1027965 - CreateException: Can't have a partition outside the disk!
CreateException: Can't have a partition outside the disk!
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:0fa7a26829443040bdd3bf4f6b9...
: CommonBugs
Depends On:
Blocks: F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-11-07 08:37 EST by Martin Krizek
Modified: 2013-12-02 07:30 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-02 07:30:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (581.59 KB, text/plain)
2013-11-07 08:37 EST, Martin Krizek
no flags Details
File: anaconda.log (33.09 KB, text/plain)
2013-11-07 08:37 EST, Martin Krizek
no flags Details
File: environ (404 bytes, text/plain)
2013-11-07 08:37 EST, Martin Krizek
no flags Details
File: lsblk_output (1.61 KB, text/plain)
2013-11-07 08:37 EST, Martin Krizek
no flags Details
File: nmcli_dev_list (4.26 KB, text/plain)
2013-11-07 08:37 EST, Martin Krizek
no flags Details
File: os_info (291 bytes, text/plain)
2013-11-07 08:37 EST, Martin Krizek
no flags Details
File: program.log (29.40 KB, text/plain)
2013-11-07 08:38 EST, Martin Krizek
no flags Details
File: storage.log (58.44 KB, text/plain)
2013-11-07 08:38 EST, Martin Krizek
no flags Details
File: syslog (65.43 KB, text/plain)
2013-11-07 08:38 EST, Martin Krizek
no flags Details
File: ifcfg.log (650 bytes, text/plain)
2013-11-07 08:38 EST, Martin Krizek
no flags Details
File: packaging.log (340.04 KB, text/plain)
2013-11-07 08:38 EST, Martin Krizek
no flags Details

  None (edit)
Description Martin Krizek 2013-11-07 08:37:25 EST
Description of problem:
In custom partitioning, I entered desired capacity of existing standard partition more than is available; I entered 100 GB while the disk is only 20GB.

Version-Release number of selected component:
anaconda-20.25.6-1

The following was filed automatically by anaconda:
anaconda 20.25.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/parted/geometry.py", line 55, in __init__
    self.__geometry = _ped.Geometry(self.device.getPedDevice(), start, length)
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 41, in new
    ret = fn(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 1573, in _computeResize
    length=newLen)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 1263, in _setTargetSize
    (constraint, geometry) = self._computeResize(self.partedPartition)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 605, in <lambda>
    lambda s, v: s._setTargetSize(v),
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 400, in __init__
    self.device.targetSize = newsize
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1250, in resizeDevice
    self.devicetree.registerAction(action_class(device, new_size))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1454, in _save_right_side
    self.__storage.resizeDevice(device, size)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2802, in on_apply_clicked
    self._save_right_side(self._current_selector)
CreateException: Can't have a partition outside the disk!

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta

Potential duplicate: bug 974593
Comment 1 Martin Krizek 2013-11-07 08:37:33 EST
Created attachment 821126 [details]
File: anaconda-tb
Comment 2 Martin Krizek 2013-11-07 08:37:39 EST
Created attachment 821127 [details]
File: anaconda.log
Comment 3 Martin Krizek 2013-11-07 08:37:44 EST
Created attachment 821128 [details]
File: environ
Comment 4 Martin Krizek 2013-11-07 08:37:47 EST
Created attachment 821129 [details]
File: lsblk_output
Comment 5 Martin Krizek 2013-11-07 08:37:53 EST
Created attachment 821130 [details]
File: nmcli_dev_list
Comment 6 Martin Krizek 2013-11-07 08:37:57 EST
Created attachment 821131 [details]
File: os_info
Comment 7 Martin Krizek 2013-11-07 08:38:01 EST
Created attachment 821132 [details]
File: program.log
Comment 8 Martin Krizek 2013-11-07 08:38:05 EST
Created attachment 821133 [details]
File: storage.log
Comment 9 Martin Krizek 2013-11-07 08:38:09 EST
Created attachment 821134 [details]
File: syslog
Comment 10 Martin Krizek 2013-11-07 08:38:15 EST
Created attachment 821135 [details]
File: ifcfg.log
Comment 11 Martin Krizek 2013-11-07 08:38:20 EST
Created attachment 821136 [details]
File: packaging.log
Comment 12 Petr Schindler 2013-11-07 08:44:47 EST
I tried to resize existing standart partition (/boot from previous installation) to size which is greater then available space.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
package:        anaconda-20.25.6-1
product:        Fedora
reason:         CreateException: Can't have a partition outside the disk!
release:        Cannot get release name.
version:        20-Beta
Comment 13 Martin Krizek 2013-11-07 09:05:33 EST
Proposing as F20 Beta blocker per criterion: "Custom partitioning: Reject or disallow invalid disk and volume configurations without crashing."
Comment 14 Mike Ruckman 2013-11-07 13:20:31 EST
Discussed in the 2013-11-07 Go/No-Go meeting [1]. Voted as a RejectedBlocker. While unfortunate, this is a resize issue which is not covered by the F20 beta release criteria. Thus, it is rejected as a release blocking issue for fedora 20 beta. Please re-propose as a F20 final blocker and mark for inclusion in CommonBugs

[1] http://meetbot.fedoraproject.org/meetbot/meetbot/fedora-meeting-2/2013-11-07/
Comment 15 Adam Williamson 2013-11-12 19:23:59 EST
Proposing as a final blocker, per criterion cited in c#13, with resize issues acceptable as Final blockers, I guess (we really need to improve that criterion ambiguity..)
Comment 16 Adam Williamson 2013-11-13 13:00:42 EST
Discussed at 2013-11-13 blocker review meeting - http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-13/f20-final-blocker-review-1.2013-11-13-17.01.log.txt . Accepted as a blocker per criterion cited in c#13.
Comment 17 Adam Williamson 2013-11-20 14:38:01 EST
Status reviewed at 2013-11-20 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-20/f20-blocker-review.2013-11-20-17.00.log.txt . This bug seems to be clearly defined and reproducible and is now just waiting in the queue to be fixed by anaconda devs.
Comment 18 Kamil Páral 2013-12-02 06:39:59 EST
I can't reproduce this with TC3. Martin, Petr, can you? If you can't, please close this, anaconda from TC3 is in stable repo.
Comment 19 Martin Krizek 2013-12-02 07:30:04 EST
I can't reproduce it either.

Note You need to log in before you can comment on or make changes to this bug.