Bug 102798 - Set the correct domain to show localized help option message
Set the correct domain to show localized help option message
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: popt (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-21 05:28 EDT by Nakai
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-21 10:58:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff for popthelp.c (689 bytes, patch)
2003-08-21 05:29 EDT, Nakai
no flags Details | Diff
ja.po under rpm/popt/po/ directory which you shouldn't miss (2.41 KB, text/plain)
2003-08-21 05:30 EDT, Nakai
no flags Details

  None (edit)
Description Nakai 2003-08-21 05:28:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.2.1) Gecko/20030225

Description of problem:
popt help option is gettextized but there is no
domain specification, so that is as same as nothing
even while translators translate so much.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. msgfmt -o /usr/share/locale/ja/LC_MESSAGES/popt.mo popt-ja.po
2. Run LANG=ja_JP.eucJP gnumeric --help
3. See the description of --help or --usage. Localized?
    

Actual Results:  English

Expected Results:  Japanese

Additional info:

This bug prevents whooole GNOME/GTK+2 apps from showing
up the fully localized help option messages, for all languages...

And, the is a trivial fix.
Comment 1 Nakai 2003-08-21 05:29:32 EDT
Created attachment 93811 [details]
diff for popthelp.c
Comment 2 Nakai 2003-08-21 05:30:31 EDT
Created attachment 93812 [details]
ja.po under rpm/popt/po/ directory which you shouldn't miss
Comment 3 Jeff Johnson 2003-08-21 10:58:04 EDT
Added in CVS, should be in popt-1.8.1-0.32 when built.

Thanks for the patch.
Comment 4 Bill Nottingham 2003-08-22 11:18:49 EDT
*** Bug 102254 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.