This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 102799 - clicking on window no longer brings it to front.
clicking on window no longer brings it to front.
Status: CLOSED UPSTREAM
Product: Red Hat Linux Beta
Classification: Retired
Component: metacity (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-21 07:12 EDT by David Woodhouse
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-04 01:03:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2003-08-21 07:12:15 EDT
In previous versions of Red Hat Linux, clicking on a window would bring it to
the front of other windows which overlapped it. That no longer works -- you
can't bring a window to the front with the mouse unless you can see its title
bar or a border.

This is surprisingly painful -- I hadn't realised how often I used this :)

I can't see any way to enable it again.
Comment 1 Michael Lee Yohe 2003-08-22 14:44:18 EDT
I can't reproduce this with the latest Rawhide Metacity.  What version are you
running?  And what applications are you testing with?
Comment 2 David Woodhouse 2003-09-25 10:51:29 EDT
Every version of metacity which has been in Severn since I reported the bug, and
all applications. 

Hitting Alt-Button1 brings a window to the front; just Button1 doesn't.
Comment 3 Havoc Pennington 2003-10-04 01:03:24 EDT
Moved to http://bugzilla.gnome.org/show_bug.cgi?id=115072

Note You need to log in before you can comment on or make changes to this bug.