Bug 1028023 - Buffer defrag not working
Buffer defrag not working
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER4
: 6.0
Assigned To: Van Halbert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 08:56 EST by Van Halbert
Modified: 2014-07-09 01:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The buffer defrag task is not working as expected because the header values are written by an object output stream, not as standalone values into the block data.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 15:56:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-2714 Major Closed Buffer defrag not working 2014-04-21 07:25:23 EDT

  None (edit)
Comment 1 JBoss JIRA Server 2013-11-07 13:15:14 EST
Steven Hawkins <shawkins@redhat.com> made a comment on jira TEIID-2714

added org.teiid.compactBufferFiles system property to the admin guide to keep more compact buffer file, defaults to false.  This could be tweaked further as the defrag/truncate cycle is initiated after 2^14 block removals.  Given that a typical allocation is around 64k this should reclaim space after a turn over of several hundred megs to a gig (note that we'll be somewhat compact already since we assign blocks from the start of the files).
Comment 2 belong 2013-12-09 19:51:58 EST
Assuming this will be set to VERIFIED before GA - setting requires_doc_text- accordingly.
Comment 3 wgibson 2014-02-11 12:51:12 EST
Covered by unit tests:  TestBufferFrontedFileStoreCache.java, TestFileStorageManager.java, and TestEnginePerformance.java.
Comment 4 JBoss JIRA Server 2014-04-21 07:25:29 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-2714 to Closed

Note You need to log in before you can comment on or make changes to this bug.