Bug 1028039 - AD Enumeration reads data from LDAP while regular lookups connect to GC
AD Enumeration reads data from LDAP while regular lookups connect to GC
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 09:20 EST by Dmitri Pal
Modified: 2014-06-18 00:03 EDT (History)
6 users (show)

See Also:
Fixed In Version: sssd-1.11.2-35.el7
Doc Type: Known Issue
Doc Text:
When enumerating users and groups, the SSSD utility connects to the lightweight directory access protocol (LDAP) port automatically, but when performing regular lookups, SSSD connects to the Global Catalog. As a consequence, if SSSD is configured to honor POSIX attributes while at the same time enumeration is selected (not default), and the POSIX attributes are not replicated to the Global Catalog, the user sees different results when enumerating users than when users' lookups are performed. To work around this problem, POSIX attributes have to be replicated to the Global Catalog, or enumeration must be disabled at the moment.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:19:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2013-11-07 09:20:04 EST
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/2142

We have a bad inconsistency when performing lookups. When enumerating users and groups, we connect to LDAP port automatically, while when doing regular lookups, we connect to GC.

This can have very confusing consequences if POSIX attributes are requested but not replicated to GC -- the users that are enumerated will show up with POSIX attributes, but since initgroups are performed against GC, the attributes not present in GC but present in LDAP are deleted from sysdb.
Comment 1 Jakub Hrozek 2013-11-29 06:21:40 EST
Hi Milan,

I'd like a slight change in the docs text, the last sentence should read "POSIX attributes must be replicated to GC *OR* enumeration disabled." Doing one of the two is enough.
Comment 3 Jeremy Agee 2014-01-30 09:39:50 EST
first check on sssd-1.11.2-37.el7 looks like we resolved the subdomain enum issue for trusted domains when using idmap.

enumerate=true
subdomain_enumerate=all

administrator@sssdad.com:*:498200500:498200513:Administrator:/home/sssdad.com/administrator:/bin/bash
guest@sssdad.com:*:498200501:498200514:Guest:/home/sssdad.com/guest:/bin/bash
administrator@child1.sssdad.com:*:1184400500:1184400500:Administrator:/home/child1.sssdad.com/administrator:/bin/bash
guest@child1.sssdad.com:*:1184400501:1184400501:Guest:/home/child1.sssdad.com/guest:/bin/bash
administrator@sssdad_tree.com:*:525400500:525400500:Administrator:/home/sssdad_tree.com/administrator:/bin/bash
guest@sssdad_tree.com:*:525400501:525400501:Guest:/home/sssdad_tree.com/guest:/bin/bash

Checking current automation task next
Comment 4 Jeremy Agee 2014-04-02 11:32:13 EDT
Test first checks posix data for users where attributes are not replicated to GC but enum is disabled. The second check confirms when enum is enabled but GC does not have attributes enum lookups will fail as documented.

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: ad_forest_10: bz 1028039 enumeration reads data from ldap while regular lookups connect to gc
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: checking uid for posixuser1_dom1@sssdad.com (Assert: 100001 should equal 100001)
:: [   PASS   ] :: checking gid for posixuser1_dom1@sssdad.com (Assert: 100001 should equal 100001)
:: [   PASS   ] :: checking homedir for posixuser1_dom1@sssdad.com (Assert: /home2/sssdad.com/posixuser1_dom1 should equal /home2/sssdad.com/posixuser1_dom1)
:: [   PASS   ] :: checking shell for posixuser1_dom1@sssdad.com (Assert: /bin/ksh should equal /bin/ksh)
:: [   PASS   ] :: checking uid for posixuser1_dom2@sssdad_tree.com (Assert: 100002 should equal 100002)
:: [   PASS   ] :: checking gid for posixuser1_dom2@sssdad_tree.com (Assert: 100002 should equal 100002)
:: [   PASS   ] :: checking homedir for posixuser1_dom2@sssdad_tree.com (Assert: /home2/sssdad_tree.com/posixuser1_dom2 should equal /home2/sssdad_tree.com/posixuser1_dom2)
:: [   PASS   ] :: checking shell for posixuser1_dom2@sssdad_tree.com (Assert: /bin/ksh should equal /bin/ksh)
:: [   PASS   ] :: checking uid for posixuser1_dom3@child1.sssdad.com (Assert: 100003 should equal 100003)
:: [   PASS   ] :: checking gid for posixuser1_dom3@child1.sssdad.com (Assert: 100003 should equal 100003)
:: [   PASS   ] :: checking homedir for posixuser1_dom3@child1.sssdad.com (Assert: /home2/child1.sssdad.com/posixuser1_dom3 should equal /home2/child1.sssdad.com/posixuser1_dom3)
:: [   PASS   ] :: checking shell for posixuser1_dom3@child1.sssdad.com (Assert: /bin/ksh should equal /bin/ksh)
:: [   PASS   ] :: Expected enumeration failure: (OK posixuser1_dom1@sssdad.com)  (FAIL posixuser1_dom2@sssdad_tree.com)  (FAIL posixuser1_dom3@child1.sssdad.com) 
:: [   LOG    ] :: Duration: 37s
:: [   LOG    ] :: Assertions: 13 good, 0 bad
:: [   PASS   ] :: RESULT: ad_forest_10: bz 1028039 enumeration reads data from ldap while regular lookups connect to gc
Comment 5 Ludek Smid 2014-06-13 06:19:00 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.