Bug 1028098 - Create repo: When accidentally selecting a GPG key, no way to deselect that key
Create repo: When accidentally selecting a GPG key, no way to deselect that key
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Walden Raines
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 11:28 EST by Corey Welton
Modified: 2016-04-22 10:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:06:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blank line available to deselect the gpg-key (87.67 KB, image/png)
2014-06-05 02:39 EDT, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 5947 None None None 2016-04-22 10:58 EDT

  None (edit)
Description Corey Welton 2013-11-07 11:28:25 EST
Description of problem:
When user is creating a yum/puppet repo and accidentally chooses something from the GPG key box, s/he is unable to "deselect" it since the 'blank' line in the dropdown disappears.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create a GPG key
2.  Attempt to create a repo (either yum or puppet);  click on the GPG key dropdown, noting the blank line (nothing selected) and the GPG key you uploaded/created.
3.  Select the GPG key.
4.  Click dropdown again and try to "deselect" it.

Actual results:
No blank option, user can't deselect

Expected results:
User should always have option to clear a gpg key they accidentally were setting up.

Additional info:
Workarounds:
 Cancel/reload
 Edit the repo once created and fix the GPG key there, where we again have the blank option.
Comment 2 Brad Buckingham 2014-05-27 12:14:08 EDT
Created redmine issue http://projects.theforeman.org/issues/5947 from this bug
Comment 3 Walden Raines 2014-05-27 15:38:03 EDT
PR: https://github.com/Katello/katello/pull/4160
Comment 4 Walden Raines 2014-05-28 16:31:34 EDT
commit 7900de0811a9e36a374f67b495cd5701971e5c3c
Merge: a1bd062 b8506e4
Author: Walden Raines <walden@redhat.com>
Date:   Wed May 28 16:30:55 2014 -0400

    Merge pull request #4160 from waldenraines/5947
    
    Fixes #5947/BZ1028098 - allow selecting empty GPG key and sync plan.

commit b8506e42bf6e92ed548f88fdb7fee727c9ec41b8
Author: Walden Raines <walden@redhat.com>
Date:   Tue May 27 15:36:30 2014 -0400

    Fixes #5947/BZ1028098 - allow selecting empty GPG key and sync plan.
Comment 6 Sachin Ghai 2014-06-05 02:38:13 EDT
Verified with sat6 beta snap8 (Satellite-6.0.3-RHEL-6-20140604.0)

I can see the blank line, in create repo form, under gpg-key. Now if user wants, can deselect the key with blank line. Please see the attached screenshot for verification.
Comment 7 Sachin Ghai 2014-06-05 02:39:27 EDT
Created attachment 902412 [details]
blank line available to deselect the gpg-key
Comment 8 Bryan Kearney 2014-07-02 10:06:41 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.