Bug 1028139 - Metric Availability auto-refresh calls are not being cleaned up properly (and grow)
Metric Availability auto-refresh calls are not being cleaned up properly (and...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Monitoring -- Other (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ER07
: JON 3.2.0
Assigned To: Mike Thompson
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 13:22 EST by Mike Thompson
Modified: 2014-01-02 15:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Thompson 2013-11-07 13:22:39 EST
Description of problem:
Availability calls increase due to the number of resources clicked in the resource tree.

The additional of state (to remember open charts) to the view keeps the browser GC from cleaning up the multiple threads. When we change resources and create a new view, there is still a link the momento object that stores the opened charts and that linkage keeps the view from being GC'd. Without the link, the view is GC'd normally and the auto-refresh activity associated with the view is destroyed with view. But when the view is not destroyed and new ones are created each on has an auto-refresh associated with it.

For instance, clicking on 10 different resources leaves 10 auto-refresh threads.

Version-Release number of selected component (if applicable): 3.2.0 ER05


How reproducible:
always


Steps to Reproduce:
1. Go to Monitoring --> Metrics tab
2. click in the resource tree to change resources
3. Go to firebug or browser console and examine how many times availability is called

Actual results:
Availability calls should not increase with changing resource links


Expected results:
Should only have 1 availability call no matter what


Additional info:
Workaround: refresh the browser
Comment 1 Mike Thompson 2013-11-07 13:25:27 EST
I had this fix in my branch mtho11/bz1014571 but that didn't make it in due to stability issues. So I'm extracting the relevant bits to place into master now.
Comment 2 Mike Thompson 2013-11-07 13:49:46 EST
Created factory methods for view creation that ensures singleton instance.

Committed to master: cee05ed
Comment 3 Mike Thompson 2013-11-07 15:04:57 EST
Committed to release/jon3.2.x as commit: 2c51610
Comment 4 Mike Thompson 2013-11-08 15:43:39 EST
Additional changes as I found it was not complete. Also removed some of the overly verbose logging to the browser console.

commit to master: e0cbede
commit to release/jon3.2.x: 979b91a
Comment 5 Simeon Pinder 2013-11-19 10:48:58 EST
Moving to ON_QA as available for testing with new brew build.
Comment 6 Simeon Pinder 2013-11-22 00:14:24 EST
Mass moving all of these from ER6 to target milestone ER07 since the ER6 build was bad and QE was halted for the same reason.
Comment 7 Filip Brychta 2013-12-02 04:47:11 EST
Verified on
Version :	
3.2.0.ER7
Build Number :	
e8e6401:ff0061d

Note You need to log in before you can comment on or make changes to this bug.