Bug 1028182 - Backport scl'ification of openshift-origin-node-proxy
Backport scl'ification of openshift-origin-node-proxy
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 15:42 EST by Jason DeTiberus
Modified: 2017-03-08 12 EST (History)
5 users (show)

See Also:
Fixed In Version: openshift-origin-node-proxy-0.9.5-1.el6op
Doc Type: Enhancement
Doc Text:
The WebSockets proxy now utilizes Node.js 0.10 from the Software Collections Library (SCL) instead of Node.js 0.6. Users must ensure their node hosts are subscribed to the Red Hat Software Collections 1 channel for this enhancement.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-13 10:06:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason DeTiberus 2013-11-07 15:42:09 EST
Description of problem:
openshift-origin-node-proxy currently relies on nodejs 0.6 which we are maintaining ourselves, upstream is using nodejs 0.10 maintained by the SCL.

Backport the changes that enabled openshift-origin-node-proxy to use the scl nodejs dependencies.
Comment 2 Jason DeTiberus 2013-11-11 11:02:35 EST
Updated version of openshift-origin-node-proxy can be found in this puddle: http://etherpad.corp.redhat.com/M8gAaXPSev
Comment 3 Johnny Liu 2013-11-12 01:09:19 EST
Verified this bug with openshift-origin-node-proxy-1.16.1-1.git.491.4d0d514.el6op.noarch, and PASS.

# rpm -q nodejs010-nodejs
nodejs010-nodejs-0.10.5-6.el6.x86_64

# rpm -qR openshift-origin-node-proxy-1.16.1-1.git.491.4d0d514.el6op.noarch
/bin/bash  
/bin/sh  
/bin/sh  
nodejs010-nodejs  
nodejs010-nodejs-async  
nodejs010-nodejs-optimist  
nodejs010-nodejs-supervisor  
nodejs010-nodejs-ws  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

# yum info nodejs010-nodejs
Loaded plugins: priorities, product-id, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
307 packages excluded due to repository priority protections
Installed Packages
Name        : nodejs010-nodejs
Arch        : x86_64
Version     : 0.10.5
Release     : 6.el6
Size        : 1.5 M
Repo        : installed
From repo   : rhel-server-rhscl-6-rpms
Summary     : JavaScript runtime
URL         : http://nodejs.org/
License     : MIT and ASL 2.0 and ISC and BSD
Description : Node.js is a platform built on Chrome's JavaScript runtime
            : for easily building fast, scalable network applications.
            : Node.js uses an event-driven, non-blocking I/O model that
            : makes it lightweight and efficient, perfect for data-intensive
            : real-time applications that run across distributed devices.
Comment 5 errata-xmlrpc 2014-01-13 10:06:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0019.html

Note You need to log in before you can comment on or make changes to this bug.