Bug 1028333 - [abrt] mock-1.1.35-1.fc20: subprocess.py:1308:_execute_child:OSError: [Errno 2] No such file or directory
[abrt] mock-1.1.35-1.fc20: subprocess.py:1308:_execute_child:OSError: [Errno ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:a1d02c0dfe1558f2e7678baed61...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 03:53 EST by Björn 'besser82' Esser
Modified: 2014-10-12 17:18 EDT (History)
5 users (show)

See Also:
Fixed In Version: mock-1.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-12 17:18:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.97 KB, text/plain)
2013-11-08 03:53 EST, Björn 'besser82' Esser
no flags Details
File: environ (166 bytes, text/plain)
2013-11-08 03:53 EST, Björn 'besser82' Esser
no flags Details

  None (edit)
Description Björn 'besser82' Esser 2013-11-08 03:53:01 EST
Description of problem:
I was invoking `mock --clean --init --shell -r fedora-rawhide-x86_64` and BANG!

Version-Release number of selected component:
mock-1.1.35-1.fc20

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python -tt /usr/sbin/mock --shell -r fedora-rawhide-x86_64
dso_list:       python-libs-2.7.5-8.fc20.x86_64
executable:     /usr/sbin/mock
kernel:         3.11.7-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
subprocess.py:1308:_execute_child:OSError: [Errno 2] No such file or directory

Traceback (most recent call last):
  File "/usr/sbin/mock", line 307, in <module>
    def do_buildsrpm(config_opts, chroot, options, args):
  File "/usr/sbin/mock", line 573, in main
    sys.exit(chroot.shell(options, cmd))
  File "/usr/lib/python2.7/site-packages/mockbuild/backend.py", line 790, in shell
    cmd=cmd)
  File "/usr/lib/python2.7/site-packages/mockbuild/util.py", line 426, in doshell
    return subprocess.call(cmdstr, preexec_fn=preexec, env=environ, shell=True)
  File "/usr/lib64/python2.7/subprocess.py", line 524, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1308, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
errread: None
c2pread: None
gc_was_enabled: True
errwrite: None
shell: True
errpipe_write: 6
executable: '/bin/sh'
close_fds: False
self: <subprocess.Popen object at 0x1771b50>
env: {'LANG': 'de_DE.utf8', 'TERM': 'vt100', 'SHELL': '/bin/bash', 'HOSTNAME': 'mock', 'PROMPT_COMMAND': 'echo -n "<mock-chroot>"', 'HOME': '/builddir', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin'}
cwd: None
child_exception: OSError(2, 'No such file or directory')
args: ['/bin/sh', '-c', '/bin/bash -i -l']
c2pwrite: None
data: 'cexceptions\nOSError\np0\n(I2\nS\'No such file or directory\'\np1\ntp2\nRp3\n(dp4\nS\'child_traceback\'\np5\nS\'Traceback (most recent call last):\\n  File "/usr/lib64/python2.7/subprocess.py", line 1265, in _execute_child\\n  File "/usr/lib64/python2.7/os.py", line 353, in execvpe\\n  File "/usr/lib64/python2.7/os.py", line 368, in _execvpe\\nOSError: [Errno 2] No such file or directory\\n\'\np6\nsb.'
creationflags: 0
errpipe_read: 5
preexec_fn: <mockbuild.util.ChildPreExec object at 0x1771ad0>
p2cread: None
startupinfo: None
p2cwrite: None
universal_newlines: False

Potential duplicate: bug 957992
Comment 1 Björn 'besser82' Esser 2013-11-08 03:53:10 EST
Created attachment 821452 [details]
File: backtrace
Comment 2 Björn 'besser82' Esser 2013-11-08 03:53:14 EST
Created attachment 821453 [details]
File: environ
Comment 3 Clark Williams 2014-01-04 15:12:52 EST
I believe that this was fixed with an libselinux update. I'll close and if this still pops up on f20, please reopen.
Comment 4 Robin Lee 2014-06-28 03:47:34 EDT
ABRT reports the same issue every time when I run 'fedora-review -n <name>'
Comment 5 Miroslav Suchý 2014-09-04 10:16:40 EDT
It happend to me when I run:
  wget https://kojipkgs.fedoraproject.org//packages/tar/1.26/12.fc18/src/tar-1.26-12.fc18.src.rpm
  mock --rebuild -r epel-6-i386 ./tar-1.26-12.fc18.src.rpm
It fails on executing:
   /bin/umount -n -l /var/lib/mock/epel-6-i386/root/proc
but on returning back to parent it raise exception
  OSError: [Errno 2] No such file or directory
Which is weird. If I stop it before calling this command and run it manualy, it pass ok as well.

Strange is that for 
  -r fedora-rawhide-x86_64 this pass without problem. However '-r epel-6-x86_64' traceback as well.

I would guess that is is the same bug as bug 947899.
Comment 6 Miroslav Suchý 2014-10-01 16:21:41 EDT
I would guess that this should be fixed as side effect of bug 1132762. Because mock does not handle /proc mounts anymore.
Comment 7 Miroslav Suchý 2014-10-12 17:18:17 EDT
Fixed in mock-1.2.0, which just landed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.