Bug 1028340 - Can't install guest through CDROM , show internal error
Can't install guest through CDROM , show internal error
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
All All
medium Severity medium
: rc
: ---
Assigned To: Ademar Reis
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 04:08 EST by chentao
Modified: 2013-12-10 12:28 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 12:28:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chentao 2013-11-08 04:08:44 EST
Description
Use virt-manager and CDROM to install a guest,it will comes an error shows:
Unable to complete install:internal error: internal error: process exited while connecting to monitor: qemu-kvm: -drive file=/dev/srO,if=none,id=drive-ide0-1-0,readonly=on,format=raw: could not open disk image /dev/srO:Driver 'host_cdrom' is not whitelisted.

Version:
libvirt-1.1.1-11.el7.x86_64
qemu-kvm-1.5.3-17.el7.x86_64
virt-manager-0.10.0-5.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.Launch virt-manager,choose Local install media(ISO image or CDROM) and through CDROM to install a windows guest.
2.Choose virtio disk with qcow2 format or ide disk with raw format.
3.Begin install the guest,errors shows:internal error: process exited while connecting to monitor: qemu-kvm: -drive file=/dev/srO,if=none,id=drive-ide0-1-0,readonly=on,format=raw: could not open disk image /dev/srO:Driver 'host_cdrom' is not whitelisted.

Actual results:
As description.

Expected results:
Guest can be installed successfully.

Additional info:
Use qemu-kvm-1.5.3-15.el7.x86_64 to install guest through CDROM also has error message:Unable to complete install: 'internal error: process exited while connecting to monitor: qemu-kvm: -drive file=/dev/sr0,if=none,id=drive-ide0-1-0,readonly=on,format=raw: could not open disk image /dev/sr0: Operation not supported
Then use qemu-kvm-1.5.3-14.el7.x86_64 don't have this issue.
Comment 2 juzhang 2013-11-19 02:53:50 EST
This should a not bug since bz[1].


[1]Bug 760885 - Disable host cdrom passthrough

Best Regards,
Junyi
Comment 3 Ademar Reis 2013-12-10 12:28:25 EST
(In reply to juzhang from comment #2)
> This should a not bug since bz[1].
> 
> 
> [1]Bug 760885 - Disable host cdrom passthrough

Indeed.

Note You need to log in before you can comment on or make changes to this bug.