Bug 1028343 - dist-geo-rep: delete operations results in a slave crash
dist-geo-rep: delete operations results in a slave crash
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Venky Shankar
Vijaykumar Koppad
: Regression, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 04:13 EST by Venky Shankar
Modified: 2014-08-24 20:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.42rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:47:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Venky Shankar 2013-11-08 04:13:06 EST
Description of problem:
Delete operations performed on the master results in geo-replication crashing on the slave.


Version-Release number of selected component (if applicable):
glusterfs-3.4.0.40.2

How reproducible:
Always

Steps to Reproduce:
1. Create files on the master
2. Allow the files to be synced to the slave
3. Delete few files from master

Actual results:
Geo-replication crashes on the slave

Expected results:
No crashes, should purge entries on the slave.
Comment 4 Vijaykumar Koppad 2013-11-13 02:28:42 EST
Tried on the build glusterfs-3.4.0.43rhs-1, it works fine now.

The steps I followed. 

1.create and start a geo-rep relationship between master and slave
2.create files one master and let it sync, ( created reg-files,symlinks, hardlink)
3.delete the files created on the master. 
4.check if it deletes everything.
Comment 5 errata-xmlrpc 2013-11-27 10:47:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.