Bug 1028374 - AttributeError: 'NoneType' object has no attribute 'type'
AttributeError: 'NoneType' object has no attribute 'type'
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:5eb25a59b656b539f68f6f653e8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 05:16 EST by Juan Orti
Modified: 2013-11-13 07:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 07:21:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1021.29 KB, text/plain)
2013-11-08 05:16 EST, Juan Orti
no flags Details
File: anaconda.log (61.16 KB, text/plain)
2013-11-08 05:16 EST, Juan Orti
no flags Details
File: environ (404 bytes, text/plain)
2013-11-08 05:16 EST, Juan Orti
no flags Details
File: lsblk_output (1.21 KB, text/plain)
2013-11-08 05:17 EST, Juan Orti
no flags Details
File: nmcli_dev_list (5.71 KB, text/plain)
2013-11-08 05:17 EST, Juan Orti
no flags Details
File: os_info (291 bytes, text/plain)
2013-11-08 05:17 EST, Juan Orti
no flags Details
File: program.log (22.73 KB, text/plain)
2013-11-08 05:17 EST, Juan Orti
no flags Details
File: storage.log (164.27 KB, text/plain)
2013-11-08 05:17 EST, Juan Orti
no flags Details
File: syslog (71.24 KB, text/plain)
2013-11-08 05:17 EST, Juan Orti
no flags Details
File: ifcfg.log (814 bytes, text/plain)
2013-11-08 05:17 EST, Juan Orti
no flags Details
File: packaging.log (645.84 KB, text/plain)
2013-11-08 05:17 EST, Juan Orti
no flags Details

  None (edit)
Description Juan Orti 2013-11-08 05:16:42 EST
Description of problem:
I created a GPT table partition in my blank disk using the text console, then switch back to the GUI and see a unknown partition, when I tried to delete it, it crashed.

Version-Release number of selected component:
anaconda-20.25.6-1

The following was filed automatically by anaconda:
anaconda 20.25.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 302, in _removeDevice
    if dev.partedPartition.type == parted.PARTITION_EXTENDED and \
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 351, in registerAction
    self._removeDevice(action.device)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1218, in destroyDevice
    self.devicetree.registerAction(action)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2077, in _destroy_device
    self.__storage.destroyDevice(device)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2201, in on_remove_clicked
    self._destroy_device(device)
AttributeError: 'NoneType' object has no attribute 'type'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta
Comment 1 Juan Orti 2013-11-08 05:16:50 EST
Created attachment 821498 [details]
File: anaconda-tb
Comment 2 Juan Orti 2013-11-08 05:16:54 EST
Created attachment 821499 [details]
File: anaconda.log
Comment 3 Juan Orti 2013-11-08 05:16:58 EST
Created attachment 821500 [details]
File: environ
Comment 4 Juan Orti 2013-11-08 05:17:02 EST
Created attachment 821501 [details]
File: lsblk_output
Comment 5 Juan Orti 2013-11-08 05:17:06 EST
Created attachment 821502 [details]
File: nmcli_dev_list
Comment 6 Juan Orti 2013-11-08 05:17:10 EST
Created attachment 821503 [details]
File: os_info
Comment 7 Juan Orti 2013-11-08 05:17:14 EST
Created attachment 821504 [details]
File: program.log
Comment 8 Juan Orti 2013-11-08 05:17:17 EST
Created attachment 821505 [details]
File: storage.log
Comment 9 Juan Orti 2013-11-08 05:17:21 EST
Created attachment 821506 [details]
File: syslog
Comment 10 Juan Orti 2013-11-08 05:17:25 EST
Created attachment 821507 [details]
File: ifcfg.log
Comment 11 Juan Orti 2013-11-08 05:17:31 EST
Created attachment 821508 [details]
File: packaging.log
Comment 12 Vratislav Podzimek 2013-11-12 08:50:55 EST
Did you use the 'Reload storage configuration from disk' button next to the minus button below the list mountpoints/systems after doing that change in console?
Comment 13 Juan Orti 2013-11-13 04:48:34 EST
(In reply to Vratislav Podzimek from comment #12)
> Did you use the 'Reload storage configuration from disk' button next to the
> minus button below the list mountpoints/systems after doing that change in
> console?

I think I didn't use that button.
Comment 14 Vratislav Podzimek 2013-11-13 07:21:57 EST
Well, then this won't be fixed, because Anaconda cannot/won't automatically find out something has changed on the disks. That's the purpose of the (maybe a bit hidden) button. I think the Installation Guide should stress that out.

Note You need to log in before you can comment on or make changes to this bug.