Bug 1028391 - python-psphere is missing dependency on PyYAML
python-psphere is missing dependency on PyYAML
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: python-psphere (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ian McLeod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 05:54 EST by Stephan Dühr
Modified: 2016-01-22 03:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 03:52:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephan Dühr 2013-11-08 05:54:35 EST
Description of problem:

>>> from psphere.client import Client
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/psphere/client.py", line 38, in <module>
    from psphere.config import _config_value
  File "/usr/lib/python2.6/site-packages/psphere/config.py", line 2, in <module>
    import yaml
ImportError: No module named yaml

Version-Release number of selected component (if applicable):
python-psphere-0.5.2-1.el6.noarch

How reproducible:


Steps to Reproduce:
1. ensure that PyYAML is not installed
2. yum install python-psphere
3. python -m psphere.client

Actual results:
Traceback (most recent call last):
  File "/usr/lib64/python2.6/runpy.py", line 122, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.6/runpy.py", line 34, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.6/site-packages/psphere/client.py", line 38, in <module>
    from psphere.config import _config_value
  File "/usr/lib/python2.6/site-packages/psphere/config.py", line 2, in <module>
    import yaml
ImportError: No module named yaml

Expected results:
After installing PyYAML:
python -m psphere.client
No handlers could be found for logger "psphere.config"

Additional info:
rpm -q python-psphere --requires
python(abi) = 2.6
python-suds  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

The following is missing the spec file:
Requires: PyYAML
Comment 1 Stephan Dühr 2016-01-22 03:52:39 EST
Looks like this was fixed with
python-psphere-0.5.2-2.el6.noarch.rpm

Also as there's python-pyvmomi now, python-psphere is obsolete.

Note You need to log in before you can comment on or make changes to this bug.