Bug 1028395 - cannot publish repository which contains more puppet modules with the same name
cannot publish repository which contains more puppet modules with the same name
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Ales Dujicek
: Triaged
Depends On: 1097209
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 06:04 EST by Ales Dujicek
Modified: 2014-07-02 10:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:04:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-11-08 06:04:47 EST
Description of problem:

if I upload to repository more puppet modules with the same name (but different authors) 
for example
http://forge.puppetlabs.com/puppetlabs/ruby
http://forge.puppetlabs.com/ecbypi/ruby

then I cannot publish that repo

> content definition publish --org org --name def --view_name view
Selected puppet repository has 1 name conflict(s) and cannot be published.

but I think it should not be problem to have more puppet modules with the same name in repository


Version-Release number of selected component (if applicable):
ruby193-rubygem-katello-foreman-engine-0.0.12-7.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-common-1.4.6-63.el6sat.noarch
katello-glue-elasticsearch-1.4.6-63.el6sat.noarch
katello-cli-1.4.3-29.el6sat.noarch
katello-all-1.4.6-63.el6sat.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-7.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-1.4.4-3.el6sat.noarch
katello-glue-candlepin-1.4.6-63.el6sat.noarch
katello-cli-common-1.4.3-29.el6sat.noarch
katello-1.4.6-63.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-7.el6sat.noarch
katello-glue-pulp-1.4.6-63.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-foreman-all-1.4.6-63.el6sat.noarch
katello-configure-1.4.7-7.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. repo content_upload --repo puppy --product product --org org --content_type puppet --filepath /tmp/ecbypi-ruby-0.0.3.tar.gz
2. repo content_upload --repo puppy --product product --org org --content_type puppet --filepath /tmp/puppetlabs-ruby-0.1.0.tar.gz
3. content definition add_repo --org org --name def --repo puppy --product product
4. content definition publish --org org --name def --view_name view

Actual results:
Selected puppet repository has 1 name conflict(s) and cannot be published.

Expected results:
Content view published successfully

Additional info:
note that it is also not possible to publish repository which contains more versions of one puppet module
Comment 1 RHEL Product and Program Management 2013-11-08 06:25:39 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Dominic Cleal 2013-11-19 13:32:56 EST
This is by design, though we could certainly make it easier + clearer.  Puppet can't distinguish between two classes with the same name - the author and version metadata are removed when installing these modules, so they look identical.  It only makes sense to have a single module per name within a published content view.
Comment 4 Bryan Kearney 2014-04-24 11:45:46 EDT
Thew new content views make this easier to manage. Moving to ON_QA.
Comment 6 Ales Dujicek 2014-06-05 09:10:03 EDT
Satellite-6.0.3-RHEL-6-20140604.0

now we have to choose one version of puppet module, so no issues with publishing content views -> verified.
Comment 7 Bryan Kearney 2014-07-02 10:04:56 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.