Bug 1028421 - Resource Agent "Delay" missing from updated resource-agents-3.9.2-21 package (RHEA-2013-1494)
Resource Agent "Delay" missing from updated resource-agents-3.9.2-21 package ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.6
All Unspecified
high Severity high
: rc
: ---
Assigned To: David Vossel
Cluster QE
: Reopened, ZStream
Depends On:
Blocks: 1032775 1032777
  Show dependency treegraph
 
Reported: 2013-11-08 07:02 EST by BugBuster666
Modified: 2014-10-14 00:59 EDT (History)
7 users (show)

See Also:
Fixed In Version: resource-agents-3.9.2-41.el6
Doc Type: Bug Fix
Doc Text:
With this update, the "Delay" resource agent has been added to the resource-agent packages as an officially supported agent.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:59:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 545873 None None None Never

  None (edit)
Description BugBuster666 2013-11-08 07:02:21 EST
Description of problem:

After updating to the latest pacemaker / resource agents release on RHEL (CentOS), (https://rhn.redhat.com/errata/RHEA-2013-1494.html) we found that the "Delay" Resource Agent is missing from the package. Before it was part of the resource-agents package.

This missing resource agents leads to unexpected cluster behaviour after the update of pacemaker and resource-agents. 

Version-Release number of selected component (if applicable):

resource-agents-3.9.2-21.el6_4.8

How reproducible:

Upgrade the resource-agents package from resource-agents-3.9.2-21.el6_4.3 to resource-agents-3.9.2-21.el6_4.8. See if "Delay" resource agents is part of the package. Delay resource agent is missing, while it was part of resource-agents version resource-agents-3.9.2-21.el6_4.3.

[root@SRV~]# LANG=C ls -al /usr/lib/ocf/resource.d/heartbeat/Delay
ls: cannot access /usr/lib/ocf/resource.d/heartbeat/Delay: No such file or directory

Steps to Reproduce:
1. install resource-agents-3.9.2-21.el6_4.3
2. verify /usr/lib/ocf/resource.d/heartbeat/Delay exists
3. upgrade resource-agents-3.9.2-21.el6_4.8
4. verify /usr/lib/ocf/resource.d/heartbeat/Delay missing

Actual results:

Resource agent /usr/lib/ocf/resource.d/heartbeat/Delay missing. 

Expected results:

Resource agent /usr/lib/ocf/resource.d/heartbeat/Delay should be within the package, as during minor version upgrades no Resource Agents should be removed !! (this update is not even a real version inclease .. to much change within an enterprise distribution). Also the removal of the Agent was not listed in the errata (https://rhn.redhat.com/errata/RHEA-2013-1494.html).

Additional info:

Please add /usr/lib/ocf/resource.d/heartbeat/Delay to resource-agents again and provide an updates package. 

Regards,
Robert
Comment 2 David Vossel 2013-11-08 10:30:25 EST
Delay is blind to whether or not the condition that is being waited on has completed or not.  This is generally not a recommended approach.

Can you describe your usage of Delay.  This agent was removed because we were unable to come up with a supportable use-case for the agent.

Thanks,
-- Vossel
Comment 3 BugBuster666 2013-11-08 11:13:48 EST
Hello, 

that's what Andrew B. also asked :)

Use case details here: 
  http://www.mail-archive.com/pacemaker@oss.clusterlabs.org/msg18189.html

We have a setup of load balancing via OSPF (ECMP). We must make sure that some service is stopped not before 30 seconds (or better OSPF heartbeat timeout) after the stop of the OSPF deamon (quagga). This allows seamless failover without any downtime.

- OSPF session active and traffic is routed to our load balancer
- crm node standby
- now OSPFD should be stopped
(now ~<OSPF dead detection timeout> seconds, traffic is still routed to our node, which we want to service, in our case ~10sec)
- we wait 30 seconds (with Delay)
(after ~<OSPF dead detection timeout> seconds, no more traffic to our "standby node")
- now the load balanced service should be stopped

For this we need Delay :)
Comment 4 David Vossel 2013-11-20 14:35:56 EST
This only requires a spec file change that removes the excludes line associated with the Delay agent and its man page.
Comment 10 michal novacek 2014-07-24 04:19:34 EDT
I have verified that Delay resource agent is present in
resource-agents-3.9.5-11.el6.x86_64.

-----

# rpm -q resource-agents
resource-agents-3.9.5-11.el6.x86_64

# ls -l /usr/lib/ocf/resource.d/heartbeat/Delay
-rwxr-xr-x. 1 root root 4761 Jul  7 20:17 /usr/lib/ocf/resource.d/heartbeat/Delay
Comment 11 errata-xmlrpc 2014-10-14 00:59:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1428.html

Note You need to log in before you can comment on or make changes to this bug.