Bug 1028425 - Not authorized when trying to mount luks partition (regression)
Not authorized when trying to mount luks partition (regression)
Status: CLOSED DUPLICATE of bug 983110
Product: Fedora
Classification: Fedora
Component: kde-baseapps (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 07:16 EST by Dr. David Alan Gilbert
Modified: 2013-11-08 08:33 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-08 08:33:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dr. David Alan Gilbert 2013-11-08 07:16:20 EST
Description of problem:

I've got an LVM lv on my main drive that is luks encrypted; I've been able to mount it using Dolphin under KDE since installing F20, but it's just stopped working on todays boot (yesterdays update?)with a 'Not authorized to perform operation' after i give it the luks passphrase.

It used to bring up a dialog asking me for the luks password, then dialogs asking me for my user password to be able to do the luks unlock 
I tried using cryptsetup to open the crypt device and then double click on the device for the now opened block device, but Dolphin won't mount that either.

The full error is 'An error occurred while accessing 'Home', the system responded: An unspecified error has occurred: Not authorized to perform operation'  I don't know why it's saying 'Home' since it's not labelled as Home.

Version-Release number of selected component (if applicable):

kde-baseapps-4.11.3-1.fc20.x86_64
udisks2-2.1.1-1.fc20.x86_64
udisks-1.0.4-12.fc20.x86_64

How reproducible:
Today? Totally.

Steps to Reproduce:
1. Get yourself a luks encrypted lv on your main disk
2. Open Dolphin
3. Double click on the encrypted device in the devices section of Dolphin
4. It asks for your passphrase - give it the passphrase

Actual results:
'An error occurred while accessing 'Home', the system responded: An unspecified error has occurred: Not authorized to perform operation

Expected results:
It mounts the partition.  Fc20 previously asked for user password at this point which would also be OK (although I'd prefer if it just did it like Ubuntu lets me!)

Additional info:
Comment 1 Dr. David Alan Gilbert 2013-11-08 07:20:55 EST
from udisksctl dump, prior to luksOpen:


/org/freedesktop/UDisks2/block_devices/dm_2d1:
  org.freedesktop.UDisks2.Block:
    Configuration:              []
    CryptoBackingDevice:        '/'
    Device:                     /dev/dm-1
    DeviceNumber:               64769
    Drive:                      '/'
    HintAuto:                   false
    HintIconName:
    HintIgnore:                 false
    HintName:
    HintPartitionable:          false
    HintSymbolicIconName:
    HintSystem:                 true
    Id:                         by-id-dm-name-main-crypt
    IdLabel:
    IdType:                     crypto_LUKS
    IdUUID:                     0af33ca5-b8f5-4f9b-9431-371a43459e7b
    IdUsage:                    crypto
    IdVersion:                  1
    MDRaid:                     '/'
    MDRaidMember:               '/'
    PreferredDevice:            /dev/mapper/main-crypt
    ReadOnly:                   false
    Size:                       10737418240
    Symlinks:                   /dev/disk/by-id/dm-name-main-crypt
                                /dev/disk/by-id/dm-uuid-LVM-owLDARCJYp2P1HwzFfDtHo1mhWFZfCv22RnaAJ1zw9jObosIQyEDvMyka2IoQzxy
                                /dev/disk/by-uuid/0af33ca5-b8f5-4f9b-9431-371a43459e7b
                                /dev/main/crypt
                                /dev/mapper/main-crypt
  org.freedesktop.UDisks2.Encrypted:

after doing a luks open:
/org/freedesktop/UDisks2/block_devices/dm_2d1:
  org.freedesktop.UDisks2.Block:
    Configuration:              []
    CryptoBackingDevice:        '/'
    Device:                     /dev/dm-1
    DeviceNumber:               64769
    Drive:                      '/'
    HintAuto:                   false
    HintIconName:
    HintIgnore:                 false
    HintName:
    HintPartitionable:          false
    HintSymbolicIconName:
    HintSystem:                 true
    Id:                         by-id-dm-name-main-crypt
    IdLabel:
    IdType:                     crypto_LUKS
    IdUUID:                     0af33ca5-b8f5-4f9b-9431-371a43459e7b
    IdUsage:                    crypto
    IdVersion:                  1
    MDRaid:                     '/'
    MDRaidMember:               '/'
    PreferredDevice:            /dev/mapper/main-crypt
    ReadOnly:                   false
    Size:                       10737418240
    Symlinks:                   /dev/disk/by-id/dm-name-main-crypt
                                /dev/disk/by-id/dm-uuid-LVM-owLDARCJYp2P1HwzFfDtHo1mhWFZfCv22RnaAJ1zw9jObosIQyEDvMyka2IoQzxy
                                /dev/disk/by-uuid/0af33ca5-b8f5-4f9b-9431-371a43459e7b
                                /dev/main/crypt
                                /dev/mapper/main-crypt
  org.freedesktop.UDisks2.Encrypted:

and the clear text device:
/org/freedesktop/UDisks2/block_devices/dm_2d13:
  org.freedesktop.UDisks2.Block:
    Configuration:              []
    CryptoBackingDevice:        '/org/freedesktop/UDisks2/block_devices/dm_2d1'
    Device:                     /dev/dm-13
    DeviceNumber:               64781
    Drive:                      '/'
    HintAuto:                   false
    HintIconName:
    HintIgnore:                 false
    HintName:
    HintPartitionable:          false
    HintSymbolicIconName:
    HintSystem:                 true
    Id:                         by-id-dm-name-crypt
    IdLabel:                    crypt
    IdType:                     ext4
    IdUUID:                     ce84c41a-bf5b-4c2a-a353-6fa2bfda70ea
    IdUsage:                    filesystem
    IdVersion:                  1.0
    MDRaid:                     '/'
    MDRaidMember:               '/'
    PreferredDevice:            /dev/mapper/crypt
    ReadOnly:                   false
    Size:                       10736889856
    Symlinks:                   /dev/disk/by-id/dm-name-crypt
                                /dev/disk/by-id/dm-uuid-CRYPT-LUKS1-0af33ca5b8f54f9b9431371a43459e7b-crypt
                                /dev/disk/by-label/crypt
                                /dev/disk/by-uuid/ce84c41a-bf5b-4c2a-a353-6fa2bfda70ea
                                /dev/mapper/crypt
  org.freedesktop.UDisks2.Filesystem:
    MountPoints:
Comment 2 Dr. David Alan Gilbert 2013-11-08 07:21:49 EST
and finally, udisksctl is working so it's not it's fault:

[dg@major ~]$ udisksctl mount -b /dev/dm-13
==== AUTHENTICATING FOR org.freedesktop.udisks2.filesystem-mount-system ===
Authentication is required to mount /dev/mapper/crypt
Authenticating as: Dr. David Alan Gilbert (dg)
Password: 
==== AUTHENTICATION COMPLETE ===
Mounted /dev/dm-13 at /run/media/dg/crypt.
Comment 3 Rex Dieter 2013-11-08 07:49:05 EST
Could be a variant of bug #983110 , do you have any polkit-kde-authentication-agent-1 process running in your session?
Comment 4 Dr. David Alan Gilbert 2013-11-08 08:25:25 EST
[dg@major ~]$ ps -eaf|grep pokit
dg        8147  8117  0 13:20 pts/4    00:00:00 grep --color=auto pokit

So, nope don't have any.
Comment 5 Dr. David Alan Gilbert 2013-11-08 08:25:52 EST
[dg@major ~]$ ps -eaf|grep polkit
polkitd    733     1  0 11:19 ?        00:00:02 /usr/lib/polkit-1/polkitd --no-debug
dg        8172  8117  0 13:25 pts/4    00:00:00 grep --color=auto polkit

With the right grep!
Comment 6 Rex Dieter 2013-11-08 08:33:41 EST
ok, thanks, marking as a dup then.

*** This bug has been marked as a duplicate of bug 983110 ***

Note You need to log in before you can comment on or make changes to this bug.