Bug 1028448 - Missing line breaks in README.html
Missing line breaks in README.html
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: CR1
: EAP 6.2.0
Assigned To: sgilda
Nikoleta Ziakova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 08:22 EST by Nikoleta Ziakova
Modified: 2017-10-09 20:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:55:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikoleta Ziakova 2013-11-08 08:22:51 EST
The first paragraph in README.html of every quickstart should contain line breaks <br> so it is more readable.


For example the first paragraph in jboss-eap-6.2.0.GA-quickstarts/helloworld/README.html is:

<p>Author: Pete Muir
Level: Beginner
Technologies: CDI, Servlet
Summary: Basic example that can be used to verify that the server is configured and running correctly
Target Product: EAP
Product Versions: EAP 6.1, EAP 6.2
Source: <a href="https://github.com/jboss-developer/jboss-eap-quickstarts/">https://github.com/jboss-developer/jboss-eap-quickstarts/</a></p>


In a web browser it looks like:

Author: Pete Muir Level: Beginner Technologies: CDI, Servlet Summary: Basic example that can be used to verify that the server is configured and running correctly Target Product: EAP Product Versions: EAP 6.1, EAP 6.2 Source: https://github.com/jboss-developer/jboss-eap-quickstarts/


It should look like:

Author: Pete Muir
Level: Beginner
Technologies: CDI, Servlet
Summary: Basic example that can be used to verify that the server is configured and running correctly
Target Product: EAP
Product Versions: EAP 6.1, EAP 6.2
Source: https://github.com/jboss-developer/jboss-eap-quickstarts/
Comment 1 sgilda 2013-11-08 08:37:08 EST
These tags are actually metadata used to build the jdf web site. You can see the rendered helloworld quickstart here:

http://www.jboss.org/jdf/quickstarts/jboss-as-quickstart/helloworld/

I need to see if there is a way to get it to render in the html files without breaking the web site.
Comment 2 sgilda 2013-11-08 10:21:06 EST
Discovered you can get a line break in markdown syntax by adding 2 spaces at the end of the line.

Fixed in master with this commit:
https://github.com/jboss-developer/jboss-eap-quickstarts/commit/ba59cc519fe7c7a4770e4d7274da051d6f75bbb0

Issued this pull for 6.2.x: 
https://github.com/jboss-developer/jboss-eap-quickstarts/pull/725
Comment 3 sgilda 2013-11-08 10:37:32 EST
6.2.x quickstarts are fixed with this commit:
https://github.com/jboss-developer/jboss-eap-quickstarts/commit/b5618369e27cb4cf30c3a261555f9ec9b9608a77
Comment 4 Jitka Kozana 2013-11-14 05:42:43 EST
Verified using EAP 6.2.0.CR1 bits.

Note You need to log in before you can comment on or make changes to this bug.