Bug 1028451 - Keybindings capture bugs
Keybindings capture bugs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks: 980692
  Show dependency treegraph
 
Reported: 2013-11-08 08:28 EST by Bastien Nocera
Modified: 2015-11-19 02:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:12:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 711682 None None None Never

  None (edit)
Description Bastien Nocera 2013-11-08 08:28:34 EST
From https://bugzilla.gnome.org/show_bug.cgi?id=711682:

In bug 707095, we created new keybindings that behave slightly differently for
when in the lock/unlock screens, and allowed the power key keybinding to be
used in the login screen.

However, that brought up 2 bugs in gnome-shell:
- you can't capture the same keybinding for 2 different modes (so g-s-d would
know that it's in the lock screen and make sure not to show polkit or
interactive dialogues in the lock screen)
- when in gdm, the keybinding mode is LOCK_SCREEN instead of LOGIN_SCREEN

When those 2 bugs are fixed, it should be possible to shutdown the machine by
pressing the power button in the lock screen after having changed the button's
behaviour:
gsettings set org.gnome.settings-daemon.plugins.power button-power "shutdown"

And ditto in gdm:
# cat >/etc/dconf/db/gdm.d/01-power <<EOF
[org/gnome/settings-daemon/plugins/power]
button-power="shutdown"
EOF
# dconf update

The related RHEL 7 bug is:
https://bugzilla.redhat.com/show_bug.cgi?id=980692
Comment 3 Laszlo Ersek 2014-10-10 08:14:53 EDT
May I ask if there's any news about this bug? We use the "power button" with virtual machines quite frequently. Thank you.
Comment 4 Laszlo Ersek 2015-03-16 07:30:52 EDT
Sixteen months have passed since this bug was filed, and no updates. Well done.
Comment 5 Matthias Clasen 2015-03-16 08:43:00 EDT
Florian, did the upstream fix for this go into 3.14 ?
Comment 6 Florian Müllner 2015-03-21 12:34:45 EDT
(In reply to Matthias Clasen from comment #5)
> Florian, did the upstream fix for this go into 3.14 ?

No, 3.16 only. The patches themselves should be easy enough to backport, but they change private API between gnome-shell and gnome-settings-daemon, so some coordination is required.
Comment 11 errata-xmlrpc 2015-11-19 02:12:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2216.html

Note You need to log in before you can comment on or make changes to this bug.