Bug 1028471 - merge "Migrate" and "Cancel Migration" buttons
merge "Migrate" and "Cancel Migration" buttons
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
low Severity low (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: nobody nobody
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 09:22 EST by David Jaša
Modified: 2016-03-10 05:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 05:11:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-11-08 09:22:24 EST
Description of problem:
since "Migrate" makes only sense when "Cancel Migration" is redundant and vice versa, these button could be merged to a single button with label changing based on VM(s) state in order to save space.
When multiple VMs are selected, current logic may be maintained: if all selected VMs are migrate-able (up and not pinned and not in-migration), "Migrate" button is available, if not, the button is disabled.

Version-Release number of selected component (if applicable):
3.3

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Michal Skrivanek 2014-02-28 04:53:01 EST
Malini, what do you think about dynamically changing the button/action?

I can think of in multiple selection case is that if I trigger a mass migration and then some of them fail but most of them are migrating…and I still have the highlighted selection - I would like to be able to cancel the remaining ongoing migrations by a single click.
Other than that functionally it's ok, I think.
Comment 2 Omer Frenkel 2015-08-26 10:01:14 EDT
moving the UX question to Einav
Comment 3 Einav Cohen 2015-08-26 11:39:57 EDT
(In reply to Michal Skrivanek from comment #1)
> Malini, what do you think about dynamically changing the button/action?
> 
> I can think of in multiple selection case is that if I trigger a mass
> migration and then some of them fail but most of them are migrating…and I
> still have the highlighted selection - I would like to be able to cancel the
> remaining ongoing migrations by a single click.

... or re-trigger the migration for the ones that failed. 
So I think that the scenario of multi-selection (in which you have both migrating and non-migrating VMs) in which we cannot guess what the user would want to do, is a good enough reason for keeping both of the 'Migrate' and 'Cancel Migration' buttons in place.
Comment 4 Red Hat Bugzilla Rules Engine 2015-11-30 15:43:04 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Note You need to log in before you can comment on or make changes to this bug.