Bug 1028496 - Resolution doesn't get synced on resize
Resolution doesn't get synced on resize
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-vdagent (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Default Assignee for SPICE Bugs
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 10:24 EST by Tomas Jamrisko
Modified: 2014-07-07 07:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-07 07:51:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2013-11-08 10:24:30 EST
Description of problem:
Changing windows size of any client doesn't result in guest matching its resolution

Version-Release number of selected component (if applicable):
spice-vdagent.0.14.0-5.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. connect to a RHEL7 guest
2. resize window

Actual results:
No change in resolution until opening a second display

Additional info:
Agent seems to be running as copy paste is working properly.
Comment 3 Christophe Fergeau 2014-01-29 10:51:34 EST
What is the host OS?
Comment 4 David Blechter 2014-01-31 10:14:22 EST
added needinfo to reporter to answer the question in #3
Comment 5 Tomas Jamrisko 2014-02-04 08:01:24 EST
The host was RHEL7, 

Tried it again and it seems to work now. So closing this bug...
Comment 6 Vaclav Ehrlich 2014-02-28 11:48:10 EST
Well I want to reopen this bug, because the behaviour is less or more strange. Auto resizing is not working when you enlarge/reduce remote-viewer window. 
Resize with xrandr/gnome settings is working good, but then second display is actived, previous dimensions are restored. Size of display are somehow remembered.

Host, Guest, Client are the same : RHEL7/64
spice-vdagentd is running.

Step to reproduce (Prologue):
1. Start guest [1]
2. Connect to guest [2] Let guest has resolution set up to 1024x768
3. Open second display (on client's remote-viewer select from menu View->Displays->Display 2)
4. Set up resolution of first display to 800x600
5. Close second window (on client's remote-viewer unselect from menu View->Displays->Display 2)

Expected result:
Second display disapears, First remains the same

Current result:
First display's resolution is set back to resolution which was at the end of step 2 (1024x768)

Step to reproduce (Main chapter):
6.Resize window of remote-viewer (grab the corner and pull)

Expected result:
Resolution is changed

Current result:
Resolution remains the same, only remote-viewer window is resized

Step to reproduce (Epilogue):
7. Enlarge remote-viewer window more than 800x600 
8. Open second display again

Expected result:
Second display appears, first remains enlarged (with correct resolution, but...)

Current result:
Second display appears, first goes back to 800x600(as previously set when second display was actived)


[1]
/usr/libexec/qemu-kvm -m 2048 -name rhel7 -drive file=path_to_RHEL7_img,media=disk -vga qxl -spice port=3000,disable-ticketing,addr=localhost,seamless-migration=on -device virtio-serial -chardev spicevmc,id=vdagent,name=vdagent -device virtserialport,chardev=vdagent,name=com.redhat.spice.0 -soundhw hda -monitor stdio

[2]
remote-viewer spice://localhost?port=3000
Comment 9 Marc-Andre Lureau 2014-07-06 18:50:43 EDT
testing on rhel7 host, with user logged in (in gdm there is bug #1052172) it works for me now. could you verify? thanks
Comment 10 Tomas Jamrisko 2014-07-07 07:51:45 EDT
Works for me now as well.

Note You need to log in before you can comment on or make changes to this bug.