Bug 1028517 - Errors in cluster-ha-singleton quickstart
Errors in cluster-ha-singleton quickstart
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: CR1
: EAP 6.2.0
Assigned To: sgilda
Jitka Kozana
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 11:07 EST by Jitka Kozana
Modified: 2013-12-15 11:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:20:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jitka Kozana 2013-11-08 11:07:00 EST
EAP 6.2.0.ER7, quickstart cluster-ha-singleton.

The prefix "jboss-as-" was since 6.2.0.ER6 replaced by "jboss-" from the name of the jar, but stayed in the source codes, causing:
- the quickstart app cannot be deployed (see exception [1])
- the client side of the code cannot be executed (see exception [2])

[1]
16:15:16,683 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-8) MSC000001: Failed to start service jboss.quickstart.ha.singleton.timer.service: org.jboss.msc.service.StartException in service jboss.quickstart.ha.singleton.timer.service: Could not initialize timer
	at org.jboss.as.quickstarts.cluster.hasingleton.service.ejb.HATimerService.start(HATimerService.java:76)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_04]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_04]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_04]
Caused by: javax.naming.NameNotFoundException: global/jboss-as-cluster-ha-singleton-service/SchedulerBean!org.jboss.as.quickstarts.cluster.hasingleton.service.ejb.Scheduler -- service jboss.naming.context.java.global.jboss-as-cluster-ha-singleton-service."SchedulerBean!org.jboss.as.quickstarts.cluster.hasingleton.service.ejb.Scheduler"
	at org.jboss.as.naming.ServiceBasedNamingStore.lookup(ServiceBasedNamingStore.java:103)
	at org.jboss.as.naming.NamingContext.lookup(NamingContext.java:197)
	at org.jboss.as.naming.InitialContext.lookup(InitialContext.java:120)
	at org.jboss.as.naming.NamingContext.lookup(NamingContext.java:183)
	at org.jboss.as.naming.NamingContext.lookup(NamingContext.java:179)
	at javax.naming.InitialContext.lookup(InitialContext.java:411) [rt.jar:1.7.0_04]
	at org.jboss.as.quickstarts.cluster.hasingleton.service.ejb.HATimerService.start(HATimerService.java:74)
	... 5 more


[2]
Lookup Bean name is ejb:/jboss-as-cluster-ha-singleton-service/ServiceAccessBean!org.jboss.as.quickstarts.cluster.hasingleton.service.ejb.ServiceAccess
Exception in thread "main" java.lang.IllegalStateException: EJBCLIENT000025: No EJB receiver available for handling [appName:, moduleName:jboss-as-cluster-ha-singleton-service, distinctName:] combination for invocation context org.jboss.ejb.client.EJBClientInvocationContext@1353488e
	at org.jboss.ejb.client.EJBClientContext.requireEJBReceiver(EJBClientContext.java:729)
	at org.jboss.ejb.client.ReceiverInterceptor.handleInvocation(ReceiverInterceptor.java:116)
	at org.jboss.ejb.client.EJBClientInvocationContext.sendRequest(EJBClientInvocationContext.java:183)
	at org.jboss.ejb.client.EJBInvocationHandler.sendRequestWithPossibleRetries(EJBInvocationHandler.java:253)
	at org.jboss.ejb.client.EJBInvocationHandler.doInvoke(EJBInvocationHandler.java:198)
	at org.jboss.ejb.client.EJBInvocationHandler.doInvoke(EJBInvocationHandler.java:181)
	at org.jboss.ejb.client.EJBInvocationHandler.invoke(EJBInvocationHandler.java:144)
	at $Proxy0.getNodeNameOfTimerService(Unknown Source)
	at org.jboss.as.quickstarts.cluster.hasingleton.service.client.SingletonServiceClient.getServiceNodeName(SingletonServiceClient.java:54)
	at org.jboss.as.quickstarts.cluster.hasingleton.service.client.SingletonServiceClient.main(SingletonServiceClient.java:67)
Comment 2 Jitka Kozana 2013-11-15 02:55:18 EST
Verified using 6.2.0.CR1 bits.

Note You need to log in before you can comment on or make changes to this bug.