This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 1028521 - Review Request: perl-DBD-ODBC - ODBC Driver for DBI
Review Request: perl-DBD-ODBC - ODBC Driver for DBI
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 11:16 EST by Jan Holcapek
Modified: 2013-12-13 22:25 EST (History)
3 users (show)

See Also:
Fixed In Version: perl-DBD-ODBC-1.45-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-04 01:55:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
lkundrak: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Comment 1 Jan Holcapek 2013-11-08 11:19:05 EST
Perhaps this will go smoother than https://bugzilla.redhat.com/show_bug.cgi?id=441830
Comment 2 Christopher Meng 2013-11-08 11:32:31 EST
SPEC URL is not the same one in SRPM. Dunno why you used a repoforge SPEC link.

I've committed some small changes on your github link, please check.

https://github.com/holcapek/perl-DBD-ODBC/pull/1
Comment 3 Jan Holcapek 2013-11-08 11:49:14 EST
(In reply to Christopher Meng from comment #2)
> SPEC URL is not the same one in SRPM. Dunno why you used a repoforge SPEC
> link.

My bad: https://github.com/holcapek/perl-DBD-ODBC/raw/master/perl-DBD-ODBC.spec

> I've committed some small changes on your github link, please check.
> 
> https://github.com/holcapek/perl-DBD-ODBC/pull/1

As far as I can tell, that looks good. I'm just wondering why did you remove all the perl module versions in (Build)Requires?
Comment 4 Christopher Meng 2013-11-08 12:48:00 EST
(In reply to Jan Holcapek from comment #3)
> (In reply to Christopher Meng from comment #2)
> > SPEC URL is not the same one in SRPM. Dunno why you used a repoforge SPEC
> > link.
> 
> My bad:
> https://github.com/holcapek/perl-DBD-ODBC/raw/master/perl-DBD-ODBC.spec
> 
> > I've committed some small changes on your github link, please check.
> > 
> > https://github.com/holcapek/perl-DBD-ODBC/pull/1
> 
> As far as I can tell, that looks good. I'm just wondering why did you remove
> all the perl module versions in (Build)Requires?

Because the versions are too old, even RHEL5(the oldest product still in support period) has newer version of them.
Comment 5 Lubomir Rintel 2013-11-18 04:28:28 EST
Taking this for review.
Dropping FE-NEEDSPONSOR, I'll sponsor Jan.
Comment 6 Lubomir Rintel 2013-11-18 08:36:11 EST
* Package named correctly
* Latest stable version used
* Package licensed correctly
* License tag correct
* SPEC file mostly clean and legible (see below)
* Correct compiler flags used
* Correct make flags used
* Builds fine in mock (test dependencies missing, see below)
* rpmlint happy
* Filelist sane
* Provides sane
* Requires mostly sane (some extra, see below)

0.) Please split a long line:

-%doc Changes FAQ if_you_are_taking_over_this_code.txt README README.adabas README.af README.hpux README.informix README.osx README.RH9 README.sqlserver README.unicode README.windows test_results.txt TO_DO
+%doc Changes FAQ if_you_are_taking_over_this_code.txt
+%doc README README.adabas README.af README.hpux README.informix
...

Also, are _all_ these files needed?

1.) Please add required build dependencies:

Test::Pod::Coverage
Test::Pod

2.) These are not runtime dependencies 

Requires:       perl(Test::Simple) >= 0.90
Requires:       perl(Test::Version) >= 1.002001

3.) You may want to remove old RPM artifacts, at least for Rawhide

BuildRoot, %clean section and %defattrs are no longer needed
Comment 7 Jan Holcapek 2013-11-19 08:34:20 EST
(In reply to Lubomir Rintel from comment #6)
> 0.) Please split a long line:
> 
> -%doc Changes FAQ if_you_are_taking_over_this_code.txt README README.adabas
> README.af README.hpux README.informix README.osx README.RH9 README.sqlserver
> README.unicode README.windows test_results.txt TO_DO
> +%doc Changes FAQ if_you_are_taking_over_this_code.txt
> +%doc README README.adabas README.af README.hpux README.informix
> ...
> 
> Also, are _all_ these files needed?

Well, they're not. Please have a look at the updated list.

> 1.) Please add required build dependencies:
> 
> Test::Pod::Coverage
> Test::Pod

Fixed.

> 2.) These are not runtime dependencies 
> 
> Requires:       perl(Test::Simple) >= 0.90
> Requires:       perl(Test::Version) >= 1.002001

Fixed.

> 3.) You may want to remove old RPM artifacts, at least for Rawhide
> 
> BuildRoot, %clean section and %defattrs are no longer needed

Fixed.
Comment 8 Lubomir Rintel 2013-11-19 15:20:28 EST
Thanks, seems all good to me now!

By the way, it is customary to include links to an updated SPEC file and SRPM in response comments (and bump release) so that the reviewer can easily find the latest package and check what has changed.

You can now proceed requesting the repository [1]
[1] http://fedoraproject.org/wiki/Package_SCM_admin_requests

The package is APPROVED
Comment 9 Jan Holcapek 2013-11-21 10:57:39 EST
New Package SCM Request
=======================
Package Name: perl-DBD-ODBC
Short Description: ODBC Driver for DBI
Owners: holcapek
Branches: f18 f19 f20 el6
InitialCC: lkundrak perl-sig
Comment 10 Jon Ciesla 2013-11-21 11:19:32 EST
Git done (by process-git-requests).
Comment 11 Fedora Update System 2013-11-25 07:24:36 EST
perl-DBD-ODBC-1.45-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/perl-DBD-ODBC-1.45-1.el6
Comment 12 Fedora Update System 2013-11-25 07:24:46 EST
perl-DBD-ODBC-1.45-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-DBD-ODBC-1.45-1.fc19
Comment 13 Fedora Update System 2013-11-25 07:24:57 EST
perl-DBD-ODBC-1.45-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-DBD-ODBC-1.45-1.fc18
Comment 14 Fedora Update System 2013-11-25 07:25:07 EST
perl-DBD-ODBC-1.45-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/perl-DBD-ODBC-1.45-1.fc20
Comment 15 Fedora Update System 2013-11-25 15:13:52 EST
perl-DBD-ODBC-1.45-1.el6 has been pushed to the Fedora EPEL 6 testing repository.
Comment 16 Fedora Update System 2013-12-04 01:55:41 EST
perl-DBD-ODBC-1.45-1.fc18 has been pushed to the Fedora 18 stable repository.
Comment 17 Fedora Update System 2013-12-04 01:58:28 EST
perl-DBD-ODBC-1.45-1.fc19 has been pushed to the Fedora 19 stable repository.
Comment 18 Fedora Update System 2013-12-10 15:04:52 EST
perl-DBD-ODBC-1.45-1.el6 has been pushed to the Fedora EPEL 6 stable repository.
Comment 19 Fedora Update System 2013-12-13 22:25:32 EST
perl-DBD-ODBC-1.45-1.fc20 has been pushed to the Fedora 20 stable repository.

Note You need to log in before you can comment on or make changes to this bug.