Bug 1028548 - Improve visibility of empty domains shared with you
Improve visibility of empty domains shared with you
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Management Console (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Jordan Liggitt
libra bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 13:33 EST by Fusepool Admin
Modified: 2015-05-14 21:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:29:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fusepool Admin 2013-11-08 13:33:19 EST
Description of problem: After domain name change (https://openshift.redhat.com/app/console/settings) the
previous domain name cannot be reused and appears as taken but this can't be the case because it's just minutes in between. Tried after hours and days but same result.

Version-Release number of selected component (if applicable):


How reproducible: because of potentially 'losing' domain names, no further changes made to reproduce the error


Steps to Reproduce:
1. changed domain name from fusepool to swissdat in account openshift@swissdat.com
2. added domain name fusepool in account admin@fusepool.net and logged out
3. after log in to account admin@fusepool.net domain name fusepool is gone, appears as taken

Actual results: domain disappeared in account admin@fusepool.net


Expected results: domain fusepool remains in account admin@fusepool.net


Additional info: Not sure if there was a malicious use in between the two log ins. Is there a way to track who logged in when?
Comment 1 Jessica Forrester 2013-11-08 16:41:51 EST
The database is showing the fusepool domain assigned to the admin@fusepool.net account. Do you still not see the domain when you go to https://openshift.redhat.com/app/console/settings ?
Comment 2 Fusepool Admin 2013-11-11 12:34:23 EST
No I have no domain and when I want to add "fusepool" but get the same error: Namespace 'fusepool' is already in use. Please choose another.
Comment 3 Jordan Liggitt 2013-11-11 14:31:40 EST
Can you attach a screenshot of https://openshift.redhat.com/app/console/domains including the login name in the top-right corner, and the list of domains?

That will help us figure out the disconnect between the DB and what you're seeing in your console.
Comment 4 Fusepool Admin 2013-11-11 16:20:25 EST
OK, i see what happened: domain fusepool is used by openshift@fusepool.net (owner) and shared to admin@fusepool.net (me). When I logged into the console, the first thing I was asked was to set up a domain. From the user interface, nothing is showing me that the domain fusepool is shared with me. Only when the link (console/domain/fusepool) was sent to me I figured out what was going on. Thanks for looking into this! Perhaps indicate on console an overview of domains shared with me.
Comment 5 Jordan Liggitt 2013-11-11 16:24:28 EST
Thanks for the update.

Lowering severity, will consider for improvement
Comment 6 Jordan Liggitt 2013-11-12 11:45:09 EST
Will merge in https://github.com/openshift/origin-server/pull/4172
Comment 7 openshift-github-bot 2013-11-12 14:57:01 EST
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/e04772e117a3d476e9a7e1c1e2ed3bb3b407ceb7
Bug 1028548: Make shared domains visible in settings if no owned domains are present
Comment 8 Yujie Zhang 2013-11-13 01:44:00 EST
Tested on devenv_4027, shared domain can be listed on settings page now, so verify this bug, thanks.

Note You need to log in before you can comment on or make changes to this bug.