Bug 10286 - Using ks.cfg produced by mkkickstart results in unbootable system
Using ks.cfg produced by mkkickstart results in unbootable system
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-21 14:03 EST by support
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-24 08:08:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description support 2000-03-21 14:03:53 EST
Before I was able to even get it to start an install using kickstart I had
to make several changes to the ks.cfg that was produced (see bug #6171)
but, even then, after the install completed, I received the following
error message:

Warning: Unable to open an initial console.
Kernel panic: No init found. Try passing init= option to kernel.

And the machine halts.  This is happening on a machine that installs and
boots just fine via a manual (non kickstart) install.  Here's the ks.cfg:

lang en_US
cdrom
keyboard us
zerombr yes
clearpart --all
part / --size 250
part swap --size 127
part /usr --size 5000 --grow
part /tmp --size 100
install
mouse genericps/2
#timezone /etc/localtime: timezone data
timezone US/Pacific
rootpw lilaboc
auth --useshadow --enablemd5
lilo --append 'mem=256M' --location mbr
%packages
ElectricFence
setup
filesystem
basesystem
ldconfig
glibc
shadow-utils
mktemp
termcap
libtermcap
bash
MAKEDEV
SysVinit
mingetty
ncurses
info
gawk
sed
e2fsprogs
chkconfig
fileutils
console-tools
procps
vixie-cron
modutils
logrotate
sysklogd
psmisc
grep
tcsh
initscripts
XFree86-libs
XFree86-xfs
chkfontpath
XFree86-75dpi-fonts
anonftp
apache
phpfi
php
php-imap
mod_perl
apache-devel
apmd
arpwatch
ash
at
authconfig
autoconf
automake
bc
bdflush
bind
bind-utils
binutils
bison
byacc
bzip2
caching-nameserver
cdecl
rmt
cpio
cpp
cproto
cracklib
cracklib-dicts
crontabs
ctags
cvs
textutils
dev
dev86
diffstat
diffutils
dump
ed
egcs
egcs-c++
eject
elm
etcskel
faces-devel
faq
fetchmail
file
findutils
finger
flex
ftp
fwhois
gd
gd-devel
gdb
gdbm
gdbm-devel
gettext
getty_ps
ghostscript
ghostscript-fonts
git
glib
glib10
kernel-headers
glibc-devel
gmp
gnupg
gpm
gpm-devel
groff
gzip
hdparm
howto
imap
indent
indexhtml
inews
ipchains
iproute
isapnptools
ispell
kbdconfig
kernel
kernel-doc
kernel-pcmcia-cs
kernel-source
knfsd-clients
kudzu
kudzu-devel
ld.so
less
lha
libc
libgr
libgr-devel
libjpeg
libjpeg-devel
libpng
libpng-devel
libstdc++
libtermcap-devel
libtiff
libtiff-devel
libungif-devel
lilo
pwdb
pam
sh-utils
redhat-release
losetup
lpg
lpr
lslk
lsof
ltrace
lynx
m4
mailcap
mailx
make
man
man-pages
mawk
metamail
mkbootdisk
mkinitrd
mkkickstart
mount
mouseconfig
mpage
mt-st
mutt
nag
nc
ncftp
ncompress
ncurses-devel
net-tools
netkit-base
newt
newt-devel
nmh
ntsysv
passwd
patch
pciutils
pciutils-devel
perl
pidentd
pine
piranha
pmake
popt
portmap
procinfo
procmail
psacct
pump
python
quota
raidtools
rcs
rdate
rdist
readline
readline-devel
redhat-logos
rgrep
rhl-gsg
rhl-ig
rhl-rg
rhs-printfilters
rootfiles
routed
rpm
rpm-devel
rpmfind
rsh
rsync
rusers
rwho
sag
sash
screen
sendmail
sendmail-cf
sendmail-doc
setconsole
setserial
setuptool
shapecfg
sharutils
slang
slang-devel
slocate
slrn
stat
strace
svgalib
svgalib-devel
swatch
symlinks
sysreport
talk
taper
tar
tcp_wrappers
tcpdump
telnet
texinfo
tftp
time
timeconfig
timed
tin
tmpwatch
traceroute
tree
trn
unarj
urlview
urw-fonts
utempter
util-linux
uucp
vim-common
vim-minimal
vlock
w3c-libwww
w3c-libwww-apps
wget
which
words
wu-ftpd
yp-tools
ypbind
zip
zlib
zlib-devel
unzip
%post
echo "Hello World."
Comment 1 support 2000-03-21 15:19:59 EST
It would appear that this error probably is not with mkkickstart or kickstart
installations... I just tried another install on this machine using the text
based install (with no ks.cfg) and got the same error after rebooting.  So, the
fact that I got this error after using a ks.cfg was probably caused by the fact
that ks.cfg also uses a text base install.  So this is perhaps an installer bug?

Side note... many of the packages listed in the graphical install are not
listed in the text install.
Comment 2 support 2000-03-21 16:50:59 EST
Ok, now I'm really confused.  Now I get this even if I try to do a graphical
install.  What is this error?  My first install (graphical) went just fine.
Now I get this error whether I'm doing a graphical or non graphical install
(without kickstart).
Comment 3 support 2000-03-21 18:44:59 EST
Ok, I may have found the problem... it would appear that it's a partitioning
problem.  I had gone from using set sizes for each of my partitions to making
my main partition "growable".  I wanted to do that so that I could use the same
partition information in my ks.cfg file for any system I used it on regardless
of hard drive size.  Unfortunately, using the "--grow" parameter in the ks.cfg
file appears to make the root partition get placed after cylinder 1024 and it
produces the error.  I'm not sure if this is a bug with the installer or the
partitioning tool.
Comment 4 Jay Turner 2000-04-24 08:08:59 EDT
Will take a look at this problem in the lab.

Note You need to log in before you can comment on or make changes to this bug.