Bug 1028616 - F20: Custom installation with most partitions as (LVM Thin Provisioning+XFS) is failing
F20: Custom installation with most partitions as (LVM Thin Provisioning+XFS) ...
Status: CLOSED DUPLICATE of bug 1013767
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
20
ppc64 All
unspecified Severity urgent
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 16:23 EST by IBM Bug Proxy
Modified: 2013-11-11 04:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 04:50:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
custom partitioning /root layout (123.81 KB, image/png)
2013-11-08 16:23 EST, IBM Bug Proxy
no flags Details
custom partitioning /boot layout (103.25 KB, image/png)
2013-11-08 16:24 EST, IBM Bug Proxy
no flags Details
Serial console logs from affected machine (16.33 KB, text/plain)
2013-11-08 16:24 EST, IBM Bug Proxy
no flags Details
Complete journalctl logs from the affected machine. (30.42 KB, text/x-log)
2013-11-08 16:24 EST, IBM Bug Proxy
no flags Details
Complete dmesg logs from the affected machine. (12.83 KB, text/x-log)
2013-11-08 16:24 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 99400 None None None Never

  None (edit)
Description IBM Bug Proxy 2013-11-08 16:23:35 EST
== Comment: #0 - Shubham Goyal <shubgoya@in.ibm.com> - 2013-11-05 04:48:28 ==
Description of problem: I tried installing Fedora 20 with a customized partition scheme. Below are the partitions I created:

/home, /boot, /, /var & swap - Most of the partitions (except /boot) were partitioned as (LVM Thin Provisioning+XFS). After proceeding with installing for above scheme the installed is entering emergency mode & dropping to dracut shell.

How reproducible: I tried twice & it was reproducible at both instances.

Steps to Reproduce:

1) Go to manual partitioning scheme.
2) Create partitions as per above scheme.
3) You will get this error during system booting post installation.

Actual results: System entering emergency mode & dracut shell

Expected results: System should be installed & come up with above mentioned scheme

Additional info: 

- Attaching snapshots of root & /boot partitioning scheme
- Attaching serial console logs 
- Attaching "journalctl" command logs

== Comment: #1 - Shubham Goyal <shubgoya@in.ibm.com> - 2013-11-05 04:52:55 ==


== Comment: #2 - Shubham Goyal <shubgoya@in.ibm.com> - 2013-11-05 04:53:41 ==


== Comment: #3 - Shubham Goyal <shubgoya@in.ibm.com> - 2013-11-05 04:54:24 ==


== Comment: #4 - Shubham Goyal <shubgoya@in.ibm.com> - 2013-11-05 04:55:10 ==


== Comment: #6 - Onkar N. Mahajan <onmahaja@in.ibm.com> - 2013-11-06 23:39:32 ==
dracut:/# uname -a
Linux junoiocplus2-lp4.austin.ibm.com 3.11.5-302.fc20.ppc64p7 #1 SMP Wed Oct 16 15:09:30 MST 2013 ppc64 ppc64 ppc64 GNU/Linux

dracut:/# cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.11.5-302.fc20.ppc64p7 root=/dev/mapper/fedora_junoiocplus2--lp4-root ro vconsole.keymap=us vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora_junoiocplus2-lp4/swap rd.lvm.lv=fedora_junoiocplus2-lp4/root LANG=en_US.UTF-8


dracut:/# dmsetup ls --tree
fedora_junoiocplus2--lp4-pool00_tdata (253:1)
 `- (8:3)
fedora_junoiocplus2--lp4-pool00_tmeta (253:0)
 `- (8:3)


dracut:/# cat /etc/fstab.empty 


dracut:/# cat /etc/fstab       
cat: /etc/fstab: No such file or directory


dracut:/# blkid
/dev/sr0: UUID="2013-10-21-20-36-03-00" LABEL="Fedora 20 ppc64" TYPE="iso9660" PTTYPE="dos" 
/dev/sda2: UUID="4eac1389-68bb-4d24-83ef-0bab16a7f499" TYPE="xfs" PARTUUID="53660500-02" 
/dev/sda3: UUID="eppQTL-uF41-0z2K-236Z-6UHC-tZft-HAOjj7" TYPE="LVM2_member" PARTUUID="53660500-03" 
/dev/mapper/fedora_junoiocplus2--lp4-pool00_tdata: LABEL="my-root" UUID="c031b7cf-3677-4e62-bb8f-19b899e2b010" TYPE="xfs" 
/dev/sda1: PARTUUID="53660500-01" 
dracut:/# blkid -o udev
ID_FS_UUID=2013-10-21-20-36-03-00
ID_FS_UUID_ENC=2013-10-21-20-36-03-00
ID_FS_LABEL=Fedora_20_ppc64
ID_FS_LABEL_ENC=Fedora\x2020\x20ppc64
ID_FS_TYPE=iso9660
ID_PART_TABLE_TYPE=dos

ID_FS_UUID=4eac1389-68bb-4d24-83ef-0bab16a7f499
ID_FS_UUID_ENC=4eac1389-68bb-4d24-83ef-0bab16a7f499
ID_FS_TYPE=xfs
ID_FS_PARTUUID=53660500-02

ID_FS_UUID=eppQTL-uF41-0z2K-236Z-6UHC-tZft-HAOjj7
ID_FS_UUID_ENC=eppQTL-uF41-0z2K-236Z-6UHC-tZft-HAOjj7
ID_FS_TYPE=LVM2_member
ID_FS_PARTUUID=53660500-03

ID_FS_LABEL=my-root
ID_FS_LABEL_ENC=my-root
ID_FS_UUID=c031b7cf-3677-4e62-bb8f-19b899e2b010
ID_FS_UUID_ENC=c031b7cf-3677-4e62-bb8f-19b899e2b010
ID_FS_TYPE=xfs

ID_FS_PARTUUID=53660500-01


dracut:/# cat /proc/mdstat 
Personalities : 
unused devices: <none>

== Comment: #7 - Onkar N. Mahajan <onmahaja@in.ibm.com> - 2013-11-06 23:39:58 ==
dracut:/# uname -a
Linux junoiocplus2-lp4.austin.ibm.com 3.11.5-302.fc20.ppc64p7 #1 SMP Wed Oct 16 15:09:30 MST 2013 ppc64 ppc64 ppc64 GNU/Linux

dracut:/# cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.11.5-302.fc20.ppc64p7 root=/dev/mapper/fedora_junoiocplus2--lp4-root ro vconsole.keymap=us vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora_junoiocplus2-lp4/swap rd.lvm.lv=fedora_junoiocplus2-lp4/root LANG=en_US.UTF-8


dracut:/# dmsetup ls --tree
fedora_junoiocplus2--lp4-pool00_tdata (253:1)
 `- (8:3)
fedora_junoiocplus2--lp4-pool00_tmeta (253:0)
 `- (8:3)


dracut:/# cat /etc/fstab.empty 


dracut:/# cat /etc/fstab       
cat: /etc/fstab: No such file or directory


dracut:/# blkid
/dev/sr0: UUID="2013-10-21-20-36-03-00" LABEL="Fedora 20 ppc64" TYPE="iso9660" PTTYPE="dos" 
/dev/sda2: UUID="4eac1389-68bb-4d24-83ef-0bab16a7f499" TYPE="xfs" PARTUUID="53660500-02" 
/dev/sda3: UUID="eppQTL-uF41-0z2K-236Z-6UHC-tZft-HAOjj7" TYPE="LVM2_member" PARTUUID="53660500-03" 
/dev/mapper/fedora_junoiocplus2--lp4-pool00_tdata: LABEL="my-root" UUID="c031b7cf-3677-4e62-bb8f-19b899e2b010" TYPE="xfs" 
/dev/sda1: PARTUUID="53660500-01" 



dracut:/# blkid -o udev
ID_FS_UUID=2013-10-21-20-36-03-00
ID_FS_UUID_ENC=2013-10-21-20-36-03-00
ID_FS_LABEL=Fedora_20_ppc64
ID_FS_LABEL_ENC=Fedora\x2020\x20ppc64
ID_FS_TYPE=iso9660
ID_PART_TABLE_TYPE=dos

ID_FS_UUID=4eac1389-68bb-4d24-83ef-0bab16a7f499
ID_FS_UUID_ENC=4eac1389-68bb-4d24-83ef-0bab16a7f499
ID_FS_TYPE=xfs
ID_FS_PARTUUID=53660500-02

ID_FS_UUID=eppQTL-uF41-0z2K-236Z-6UHC-tZft-HAOjj7
ID_FS_UUID_ENC=eppQTL-uF41-0z2K-236Z-6UHC-tZft-HAOjj7
ID_FS_TYPE=LVM2_member
ID_FS_PARTUUID=53660500-03

ID_FS_LABEL=my-root
ID_FS_LABEL_ENC=my-root
ID_FS_UUID=c031b7cf-3677-4e62-bb8f-19b899e2b010
ID_FS_UUID_ENC=c031b7cf-3677-4e62-bb8f-19b899e2b010
ID_FS_TYPE=xfs

ID_FS_PARTUUID=53660500-01


dracut:/# cat /proc/mdstat 
Personalities : 
unused devices: <none>

== Comment: #8 - Onkar N. Mahajan <onmahaja@in.ibm.com> - 2013-11-06 23:40:29 ==
dracut:/# dmesg|grep dracut
[    0.253340] systemd[1]: Starting dracut cmdline hook...

== Comment: #9 - Onkar N. Mahajan <onmahaja@in.ibm.com> - 2013-11-06 23:40:53 ==
dracut:/# lvm pvdisplay
  --- Physical volume ---
  PV Name               /dev/sda3
  VG Name               fedora_junoiocplus2-lp4
  PV Size               23.45 GiB / not usable 4.00 MiB
  Allocatable           yes 
  PE Size               4.00 MiB
  Total PE              6002
  Free PE               992
  Allocated PE          5010
  PV UUID               eppQTL-uF41-0z2K-236Z-6UHC-tZft-HAOjj7


   
dracut:/# lvm vgdisplay
  --- Volume group ---
  VG Name               fedora_junoiocplus2-lp4
  System ID             
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  12
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                5
  Open LV               0
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               23.45 GiB
  PE Size               4.00 MiB
  Total PE              6002
  Alloc PE / Size       5010 / 19.57 GiB
  Free  PE / Size       992 / 3.88 GiB
  VG UUID               cLd8vK-z82f-GqSf-IKF0-2Vzl-B9Xb-lSr4yI


   
dracut:/# lvm lvdisplay
  --- Logical volume ---
  LV Name                pool00
  VG Name                fedora_junoiocplus2-lp4
  LV UUID                xDWVYR-Oz1g-mCp6-Qc94-1hNg-KGhA-1ZsMIT
  LV Write Access        read/write
  LV Creation host, time junoiocplus2-lp4.austin.ibm.com, 2013-11-07 03:52:53 +0000
  LV Pool transaction ID 4
  LV Pool metadata       pool00_tmeta
  LV Pool data           pool00_tdata
  LV Pool chunk size     64.00 KiB
  LV Zero new blocks     yes
  LV Status              NOT available
  LV Size                19.53 GiB
  Current LE             5000
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
   
  --- Logical volume ---
  LV Path                /dev/fedora_junoiocplus2-lp4/root
  LV Name                root
  VG Name                fedora_junoiocplus2-lp4
  LV UUID                PRvhPJ-cqhN-s9eI-JrHE-GLHN-Qd9j-LrOsXd
  LV Write Access        read/write
  LV Creation host, time junoiocplus2-lp4.austin.ibm.com, 2013-11-07 03:52:54 +0000
  LV Pool name           pool00
  LV Status              NOT available
  LV Size                7.81 GiB
  Current LE             2000
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
   
  --- Logical volume ---
  LV Path                /dev/fedora_junoiocplus2-lp4/home
  LV Name                home
  VG Name                fedora_junoiocplus2-lp4
  LV UUID                oqm9mS-Q06v-dh30-dqyr-sk8Q-KNU6-iubJ4x
  LV Write Access        read/write
  LV Creation host, time junoiocplus2-lp4.austin.ibm.com, 2013-11-07 03:52:56 +0000
  LV Pool name           pool00
  LV Status              NOT available
  LV Size                2.93 GiB
  Current LE             750
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
   
  --- Logical volume ---
  LV Path                /dev/fedora_junoiocplus2-lp4/var
  LV Name                var
  VG Name                fedora_junoiocplus2-lp4
  LV UUID                lDHfjz-ssOf-z4pm-KxlR-I1Iy-1DTI-QedF7F
  LV Write Access        read/write
  LV Creation host, time junoiocplus2-lp4.austin.ibm.com, 2013-11-07 03:52:59 +0000
  LV Pool name           pool00
  LV Status              NOT available
  LV Size                3.91 GiB
  Current LE             1000
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
   
  --- Logical volume ---
  LV Path                /dev/fedora_junoiocplus2-lp4/swap
  LV Name                swap
  VG Name                fedora_junoiocplus2-lp4
  LV UUID                dju09w-nD33-UvG3-85b5-9dDK-tXTv-Ur3LYV
  LV Write Access        read/write
  LV Creation host, time junoiocplus2-lp4.austin.ibm.com, 2013-11-07 03:53:01 +0000
  LV Pool name           pool00
  LV Status              NOT available
  LV Size                4.88 GiB
  Current LE             1250
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
   
dracut:/#

== Comment: #10 - Onkar N. Mahajan <onmahaja@in.ibm.com> - 2013-11-06 23:46:13 ==


== Comment: #11 - Onkar N. Mahajan <onmahaja@in.ibm.com> - 2013-11-06 23:48:26 ==


== Comment: #12 - Onkar N. Mahajan <onmahaja@in.ibm.com> - 2013-11-07 00:14:09 ==
Shubham, 

Analyzing the logs , this problem looks similar to https://bugzilla.redhat.com/show_bug.cgi?id=1013767. 

can you check with the latest f20 alpha available ?

-- Onkar

== Comment: #17 - Onkar N. Mahajan <onmahaja@in.ibm.com> - 2013-11-08 01:14:05 ==
can you please give it a try with this ISO - 

http://ppc.koji.fedoraproject.org/stage/f20-20131107-Beta-RC5.0/Fedora/ppc64/iso/Fedora-20-Beta-ppc64-DVD.iso
Comment 1 IBM Bug Proxy 2013-11-08 16:23:50 EST
Created attachment 821792 [details]
custom partitioning /root layout
Comment 2 IBM Bug Proxy 2013-11-08 16:24:00 EST
Created attachment 821793 [details]
custom partitioning /boot layout
Comment 3 IBM Bug Proxy 2013-11-08 16:24:12 EST
Created attachment 821794 [details]
Serial console logs from affected machine
Comment 4 IBM Bug Proxy 2013-11-08 16:24:24 EST
Created attachment 821795 [details]
Complete journalctl logs from the affected machine.
Comment 5 IBM Bug Proxy 2013-11-08 16:24:37 EST
Created attachment 821796 [details]
Complete dmesg logs from the affected machine.
Comment 6 Harald Hoyer 2013-11-11 04:49:21 EST
You need dracut-034-19.git20131021

https://admin.fedoraproject.org/updates/FEDORA-2013-19603/dracut-034-19.git20131021.fc20

You have dracut-034-8.git20131008.fc20
Comment 7 Harald Hoyer 2013-11-11 04:50:12 EST

*** This bug has been marked as a duplicate of bug 1013767 ***

Note You need to log in before you can comment on or make changes to this bug.