This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1028635 - audisp-remote will not reconnect to remote server after a transient "critical" network error
audisp-remote will not reconnect to remote server after a transient "critical...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: audit (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Steve Grubb
Patrik Kis
: ZStream
Depends On: 1044628
Blocks: 1042734
  Show dependency treegraph
 
Reported: 2013-11-08 17:28 EST by John Trowbridge
Modified: 2014-10-14 03:14 EDT (History)
9 users (show)

See Also:
Fixed In Version: audit-2.2-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:14:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Trowbridge 2013-11-08 17:28:51 EST
Description of problem:

audisp will not reconnect to remote server after a transient "critical" network error. 

Additional info:

Steve Grubb is aware of this issue, and has a fix.
Comment 2 Steve Grubb 2013-11-09 08:39:59 EST
There is an upstream fix for this. Simple fix to back port just that patch.
Comment 3 Steve Grubb 2013-11-12 14:38:36 EST
The main patches that fixes this is 867 & 871.

https://fedorahosted.org/audit/changeset/867

However, that also depended on 865, 864, 863, and 860 because the management of plugins was not working correctly. Meaning that if you changed a setting in audisp-remote.conf, you could not do, "service auditd reload" and have sighup propogate to the remote plugin.
Comment 7 Ondrej Moriš 2013-12-02 09:47:11 EST
Could you please share the details about this bug and its reproducer? It is not clear from the description - what is meant by a 'transient "critical" network error.'?
Comment 14 Steve Grubb 2013-12-12 16:30:10 EST
audit-2.2-3.el6 was built with just patch 867 & 871 applied.
Comment 22 Steve Grubb 2013-12-20 09:21:51 EST
Thanks for the investigation. I can see that I need to modify the patch a bit. I will provide an updated build.
Comment 23 Steve Grubb 2014-01-27 17:09:57 EST
Fixed in upstream commit 895.
Comment 24 Steve Grubb 2014-01-27 17:27:05 EST
audit-2.2-4.el6 was built to resolve this problem. It adds upstream commit 895 to the patch.
Comment 35 Patrik Kis 2014-02-11 09:53:06 EST
When updating to the new version, please make sure that the

/etc/audisp/audisp-remote.conf

configuration file is updated too. The default value of "remote_ending_action" has changed from:

remote_ending_action = suspend

to

remote_ending_action = reconnect

This change is an important part if the fix.
Comment 38 errata-xmlrpc 2014-10-14 03:14:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1515.html

Note You need to log in before you can comment on or make changes to this bug.