Bug 1028670 - libdevmapper.so exists, but not found
libdevmapper.so exists, but not found
Status: CLOSED DUPLICATE of bug 1026545
Product: Fedora
Classification: Fedora
Component: docker-io (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-09 05:38 EST by pavel.nedr
Modified: 2014-07-01 18:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-09 09:22:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pavel.nedr 2013-11-09 05:38:17 EST
On fedora 20 x64 docker can't found existing libdevmapper.so. device-mapper-libs-1.02.82-3.fc20.x86_64 is installed.

$ sudo find / -name libdev*
...
/usr/lib64/libdevmapper-event.so.1.02
/usr/lib64/libdevmapper.so.1.02
...

$ yum info docker-io
Загружены модули: langpacks, refresh-packagekit
Установленные пакеты
Название: docker-io
Архитектура: x86_64
Версия: 0.7
Выпуск: 0.13.dm.fc20
Объем: 11 M
Источник: installed
Из источника: docker-goldmann
Аннотация: Automates deployment of containerized applications
Ссылка: http://www.docker.io
Лицензия: ASL 2.0

$ uname -a
Linux bb.lan 3.11.7-300.fc20.x86_64 #1 SMP Mon Nov 4 15:07:39 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux


Just another strange thing is that yum provides shows only i686 packages of libdevmapper.

log:

sudo docker run -i -t ubuntu /bin/bash
/.dockerinit: error while loading shared libraries: libdevmapper.so.1.02: cannot open shared object file: No such file or directory

$ yum provides libdevmapper.so.1.02
Загружены модули: langpacks, refresh-packagekit
device-mapper-libs-1.02.82-3.fc20.i686 : Device-mapper shared library
Источник: fedora
Совпадения с:
Обеспечивает    : libdevmapper.so.1.02



device-mapper-libs-1.02.82-3.fc20.i686 : Device-mapper shared library
Источник: updates-testing
Совпадения с:
Обеспечивает    : libdevmapper.so.1.02

$ sudo yum install device-mapper-libs
Загружены модули: langpacks, refresh-packagekit
Пакет device-mapper-libs-1.02.82-3.fc20.x86_64 уже установлен, и это последняя версия.   # device-mapper-libs is already installed and there is latest version
Выполнять нечего   # nothing to do
Comment 1 Matthew Miller 2013-11-09 09:22:34 EST
This is a known problem. The issue is that the library needs to exist _inside_ the container. In practice, this means you can use docker images built with the same Fedora version that docker itself was, which is of course not the intention.

This is one of the reasons we're not making the package officially available yet.

*** This bug has been marked as a duplicate of bug 1026545 ***

Note You need to log in before you can comment on or make changes to this bug.