This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1028722 - sysusage html should be stored in /var tree
sysusage html should be stored in /var tree
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sysusage (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-09 21:19 EST by Frank Crawford
Modified: 2013-11-30 21:53 EST (History)
3 users (show)

See Also:
Fixed In Version: sysusage-5.3-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 14:42:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Crawford 2013-11-09 21:19:25 EST
Description of problem:
The configuration shipped for Fedora saves updated html files in /usr/share, but should be stored in somewhere like /var/www/sysusage.

Version-Release number of selected component (if applicable):
sysusage-5.3-1.fc19.noarch

How reproducible:
100% with standard configuration

Steps to Reproduce:
1. Install with standard configuration
2. Run sysusagegraph
3. Output found in /usr/share/sysusage.

Actual results:
Results are saved in /usr/share tree, which by LFS should be for static files.

Expected results:
Results should be save in somewhere like /var/share/sysusage.

Additional info:
The issue with location static resources in /usr/share/sysusage and generated files can be /var/www/sysusage can be corrected by using RESRC_URL configuration variable.  This can be updated by creating an additional html alias superficially for the static resources and a different one for the variable images.
Comment 1 Christopher Meng 2013-11-12 00:16:16 EST
Add Peter Robinson to CC see if he can help. This location is defined by

HTMLDIR=%{_datadir}/%{name} in the spec.

BTW I don't think /var/share is a good idea.

And Fedora uses /usr/share but not /var/www in many places.
Comment 2 Peter Robinson 2013-11-12 04:09:46 EST
> HTMLDIR=%{_datadir}/%{name} in the spec.
> 
> BTW I don't think /var/share is a good idea.
> 
> And Fedora uses /usr/share but not /var/www in many places.

/usr/share is used where the websites are static and will never change (like a web mail interface) because the data is pulled from elsewhere.

sysusage has some of this (the jqplot components) but it has a lot of generated content there. In this case I think somewhere like /var/www/sysusage would make sense (/var/www is owned by a number of web servers so it would work). I had thought about this but not got as far as making a decision.

So does everyone agree /var/www/sysusage would be reasonable? It would impact upgrades, I'm not sure we can handle those as well. Just need to document them in the updates. Thoughts?
Comment 3 Frank Crawford 2013-11-12 04:56:47 EST
I don't have an issue with this, as I think /var/www/sysusage is the correct location for these sorts of files.
Comment 4 Fedora Update System 2013-11-12 06:34:14 EST
sysusage-5.3-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sysusage-5.3-5.fc20
Comment 5 Fedora Update System 2013-11-12 06:34:24 EST
sysusage-5.3-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sysusage-5.3-5.fc19
Comment 6 Fedora Update System 2013-11-12 06:34:35 EST
sysusage-5.3-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/sysusage-5.3-5.el6
Comment 7 Fedora Update System 2013-11-12 06:34:44 EST
sysusage-5.3-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sysusage-5.3-5.fc18
Comment 8 Fedora Update System 2013-11-12 20:58:53 EST
Package sysusage-5.3-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sysusage-5.3-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21129/sysusage-5.3-5.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-11-23 14:42:01 EST
sysusage-5.3-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-11-23 14:44:04 EST
sysusage-5.3-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-11-23 22:46:32 EST
sysusage-5.3-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-11-30 21:53:51 EST
sysusage-5.3-5.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.