Bug 1028726 - python-heatclient needs a dependency on python-pbr
python-heatclient needs a dependency on python-pbr
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: python-heatclient (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Ruzicka
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-09 21:54 EST by Lars Kellogg-Stedman
Modified: 2016-04-26 16:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-heatclient-0.2.6-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:04:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2013-11-09 21:54:59 EST
Description of problem:

I received a 500 error when trying to access the OpenStack dashboard after install RDO Havana on Fedora 19.  The following Python exception was in /var/log/httpd/error_log:

  [Sat Nov 09 21:46:05.382168 2013] [:error] [pid 20998] [remote 192.168.122.1:21571]     raise ImportError("Could not import settings '%s' (Is it on sys.path?): %s" % (self.SETTINGS_MODUL E, e))

This error stems from a failure a prior ImportError caused when trying to import the openstack_dashboard.settings module:

  # cd /usr/share/openstack-dashboard
  # python
  Python 2.7.5 (default, Oct  8 2013, 12:19:40) 
  [GCC 4.8.1 20130603 (Red Hat 4.8.1-1)] on linux2
  Type "help", "copyright", "credits" or "license" for more information.
  >>> import openstack_dashboard.settings
  Traceback (most recent call last):
    File "<stdin>", line 1, in <module>
    File "openstack_dashboard/settings.py", line 28, in <module>
      from openstack_dashboard import exceptions
    File "openstack_dashboard/exceptions.py", line 23, in <module>
      from heatclient import exc as heatclient
    File "/usr/lib/python2.7/site-packages/heatclient/__init__.py", line 13, in <module>
      import pbr.version
  ImportError: No module named pbr.version

This is caused by heatclient attempting to import the "pbr" module.
Install python-pbr allows the dashboard to operate successfully.
Comment 1 Jakub Ruzicka 2013-12-10 08:21:58 EST
I removed the runtime dependency on python-pbr in python-heatclient 0.2.6-2 (0.2.6-1 for epel-6)

Note You need to log in before you can comment on or make changes to this bug.