Bug 1028753 - Gnome-music bug when opening a music with bad tag
Gnome-music bug when opening a music with bad tag
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-music (Show other bugs)
20
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Mathieu Bridon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-10 07:33 EST by Alexandre Moine
Modified: 2014-04-27 05:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: gnome-music-3.10.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-11 07:44:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 710094 None None None Never

  None (edit)
Description Alexandre Moine 2013-11-10 07:33:05 EST
Description of problem:
When I try to open a music (nammed song.ogg) with an empty title tag, gnome-music crash. I run "gnome-music" in a terminal, and I select song.ogg. 
That the result:
Detected new source available: 'Tracker' and it supports search
Traceback (most recent call last):
  File "/usr/lib/python3.3/site-packages/gnomemusic/notification.py", line 85, in _update_track
    'gnome-music')
TypeError: Argument 1 does not allow None as a value


Version-Release number of selected component (if applicable):
gnome-music-3.10.1-1.fc20.x86_64


How reproducible:
Open an ogg song with an empty title tag

Steps to Reproduce:
1.
2.
3.

Actual results:
Gnome-music crash

Expected results:
Gnome-music play the music

Additional info:
Comment 1 Mathieu Bridon 2013-11-16 22:47:37 EST
Thanks for the bug report.

I don't manage to reproduce it, though.

I've just tried removing the title tag of a song, and Music now displays its filename (in my case « 1 - Track 1 (copy).flac ») then lets me play it just fine.

I have the same version of Music as you.

Not sure what's going on here...
Comment 2 Alexandre Moine 2013-11-17 04:30:31 EST
Hi,

After a test, I understood that I missed one thing.
My music have the same Artist and Album tag. The other is empty.

I upload my song: https://www.dropbox.com/s/cloyc6hq9cgjzrb/Schubert%2C%20Trio%20op.%20100%20-%20Andante%20con%20moto-e52IMaE-3As.ogg

Thank for your response :)
Comment 3 Mathieu Bridon 2013-11-17 04:55:39 EST
Just downloaded this file, saved it in ~/Music. It shows up in GNOME Music, and I can play it just fine.

Are you sure you're running the latest version?

Upstream tells me that there was a bug like this that they fixed some time ago, before the 3.10 release.
Comment 4 Alexandre Moine 2013-11-17 05:42:06 EST
Yes, I'm sure, I've got gnome-music.x86_64 0:3.10.1-1.fc20 on my computer
Comment 5 Fedora Update System 2014-04-17 10:07:44 EDT
gnome-music-3.10.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gnome-music-3.10.4-1.fc20
Comment 6 Fedora Update System 2014-04-27 05:10:08 EDT
gnome-music-3.10.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.