Bug 1028768 - [engine-backend] LSM fails due to another operation (attaching the disk snapshot to another VM), which was started after it and managed to take the lock on the disk
[engine-backend] LSM fails due to another operation (attaching the disk snaps...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Liron Aravot
Elad
storage
:
Depends On:
Blocks: 922475 3.3snap4 1054231
  Show dependency treegraph
 
Reported: 2013-11-10 10:27 EST by Elad
Modified: 2016-02-10 12:39 EST (History)
8 users (show)

See Also:
Fixed In Version: is26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:17:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: Triaged+


Attachments (Terms of Use)
engine.log (4.79 MB, application/x-gzip)
2013-11-10 10:27 EST, Elad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20847 None None None Never
oVirt gerrit 21803 None None None Never
oVirt gerrit 21804 None None None Never
oVirt gerrit 21829 None None None Never
oVirt gerrit 21834 None None None Never

  None (edit)
Description Elad 2013-11-10 10:27:41 EST
Created attachment 822102 [details]
engine.log

Description of problem:
Live storage migration fails because another operation was managed to take a lock on the disk.
Happened to me when during LSM, I tried to attach the disk snapshot to another VM with REST (as part of the new backup-API feature) 

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.32.beta1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
On a block/file pool with 2 SDs:
1. create 2 VMs with disk and run them 
2. live migrate one of the VMs disk to the second SD
3. during the LSM operation (right after it began), attach the disk snapshot (the one that is simultaneously  migrating) to the other running vm using REST

Actual results:
The disk attachment operation succeeds and LSM fails.

LSM is failing with a CanDoAction:

2013-11-10 15:56:12,613 WARN  [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (ajp-/127.0.0.1:8702-4) [47722e08] CanDoAction of action LiveMigrateVmDisks failed. Reasons:VAR__ACTION__MOVE,VAR__TYPE__VM_D
ISK,ACTION_TYPE_FAILED_VM_DISK_SNAPSHOT_IS_PLUGGED_TO_ANOTHER_VM,$disksInfo


Expected results:
The migrated disk should be locked until the live storage migration operation ends. Other operations on the same disk should be blocked.

Additional info:
engine.log
Comment 1 Elad 2013-12-15 07:05:43 EST
When trying to attach a disk snapshot to VM, while the the itself is being live migrated, the operation get blocked by engine, this is the message we get on REST:
[Cannot attach Virtual Machine Disk. Disk iscsi5-3_Disk1 is being moved or copied.]


Verified using is26
Comment 2 Itamar Heim 2014-01-21 17:17:04 EST
Closing - RHEV 3.3 Released
Comment 3 Itamar Heim 2014-01-21 17:23:42 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.