Bug 1028775 - Installer fails on Solaris 11
Installer fails on Solaris 11
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Configuration (Show other bugs)
6.0.0
Unspecified Solaris
unspecified Severity urgent
: CR2
: 6.0
Assigned To: Thomas Hauser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-10 12:55 EST by Filip Nguyen
Modified: 2014-07-09 01:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Users are having trouble starting JBoss Data Virtualization on Solaris 11. This is occuring because neither PATH nor JAVA_HOME environment variables are set. At least one of these must be set.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 14:27:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of weird error message (234.88 KB, image/png)
2013-11-10 12:55 EST, Filip Nguyen
no flags Details
Installation Log (5.58 KB, text/plain)
2013-11-10 13:22 EST, Filip Nguyen
no flags Details

  None (edit)
Description Filip Nguyen 2013-11-10 12:55:09 EST
Created attachment 822119 [details]
screenshot of weird error message

I was not able to install the DV6 on Solaris 11. It fails to start the server (It outputs failed to start server after 11 attempts and doesn't finish.) After thta it tries to configure the server anyway and weird error messages pops up. Please see the attached screenshot.


I see this behavior not only with the graphical installer, but also with the headless installer (completely automated).

Note that zip distribution works and I can start the server.

Using Java 1.7.0_40

Machine:
> cat /etc/release
                           Oracle Solaris 11 11/11 X86
  Copyright (c) 1983, 2011, Oracle and/or its affiliates.  All rights reserved.
                            Assembled 18 October 2011
Comment 1 Filip Nguyen 2013-11-10 13:22:11 EST
Created attachment 822121 [details]
Installation Log
Comment 2 Thomas Hauser 2013-11-18 10:47:20 EST
This was occuring because neither PATH nor JAVA_HOME environment variables were set. At least one of these must be set, or 


# Setup the JVM
if [ "x$JAVA" = "x" ]; then
    if [ "x$JAVA_HOME" != "x" ]; then
        JAVA="$JAVA_HOME/bin/java"
    else
        JAVA="java"
    fi
fi

This snippet within standalone.sh or domain.sh will result in a command that is not executable in the environment. This apparently fails without any kind of error message that ProcessBuilder can see, and thus is not logged in the installer.
Comment 3 Filip Nguyen 2013-11-18 11:10:38 EST
I suggest to remove blocker flag as this is not a blocking bug.
Comment 4 wgibson 2014-02-10 18:39:12 EST
DV6 installer works on Sol 11.

Note You need to log in before you can comment on or make changes to this bug.