Bug 1028777 - 3.2.1. Create a New RemoteCacheManager use deprecated API
3.2.1. Create a New RemoteCacheManager use deprecated API
Status: CLOSED DUPLICATE of bug 1028746
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 6.2.0
Assigned To: gsheldon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-10 12:56 EST by Vitalii Chepeliuk
Modified: 2013-11-11 18:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 12532, Administration and Configuration Guide-6.2-Beta-3 Build Date: 06-11-2013 16:02:50 Topic ID: 8989-523664 [Latest]
Last Closed: 2013-11-11 18:19:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitalii Chepeliuk 2013-11-10 12:56:36 EST
Title: Create a New RemoteCacheManager

Describe the issue:
Creating RemoteCacheManaget via Properties is deprecated in infinispan 6.0.0 
Properties props = new Properties();
props.put("infinispan.client.hotrod.server_list", "127.0.0.1:11222");
RemoteCacheManager manager = new RemoteCacheManager(props);
RemoteCache defaultCache = manager.getCache();

Suggestions for improvement:
ConfigurationBuilder should be used          
Configuration conf = new ConfigurationBuilder().addServer().host(<hostname|ip>).port(<port>).build();
RemoteCacheManager manager = new RemoteCacheManager(conf);
RemoteCache defaultCache = manager.getCache();

Additional information:
creating remote cache manager with constructor RemoteCacheManager(Properties props); will be dropped in next release of JDG
Comment 2 Vitalii Chepeliuk 2013-11-11 03:28:50 EST
And I forgot there is other other way to create RemoteCacheManager and RemoteCache where hotrod-client.properties are still used
RemoteCacheManager manager = new RemoteCacheManager();
RemoteCache defaultCache = manager.getCache();

This could be added to documentation If somebody wants still use this hotrod-client.properties
Comment 3 Vitalii Chepeliuk 2013-11-11 03:41:10 EST
And I forgot one more where hotrod-client.properties are still used
RemoteCacheManager manager = new RemoteCacheManager(true|false);
RemoteCache defaultCache = manager.getCache();

This could be added to documentation If somebody wants still use this hotrod-client.properties
Comment 4 gsheldon 2013-11-11 18:19:15 EST
This issue has also been raised in BZ#1028746 and will be addressed there.

Closing this bug as a duplicate.

*** This bug has been marked as a duplicate of bug 1028746 ***

Note You need to log in before you can comment on or make changes to this bug.