Bug 1028785 - [abrt] WARNING: CPU: 0 PID: 1560 at drivers/gpu/drm/i915/intel_display.c:8329 check_crtc_state+0x5af/0x9f0 [i915]()
[abrt] WARNING: CPU: 0 PID: 1560 at drivers/gpu/drm/i915/intel_display.c:8329...
Status: CLOSED DUPLICATE of bug 1027037
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6ac9c791dedad39a308757bf8ea...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-10 13:32 EST by klaus
Modified: 2014-11-18 15:18 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 15:18:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (175.26 KB, text/plain)
2013-11-10 13:32 EST, klaus
no flags Details

  None (edit)
Description klaus 2013-11-10 13:32:04 EST
Description of problem:
No idea

Additional info:
reporter:       libreport-2.1.9
WARNING: CPU: 0 PID: 1560 at drivers/gpu/drm/i915/intel_display.c:8329 check_crtc_state+0x5af/0x9f0 [i915]()
pipe state doesn't match!
Modules linked in: fuse xt_CHECKSUM des_generic md4 tun rpcsec_gss_krb5 auth_rpcgss nls_utf8 nfsv4 nfs cifs lockd sunrpc dns_resolver fscache nf_conntrack_tftp nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6t_REJECT xt_conntrack bnep bluetooth ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw snd_usb_audio snd_usbmidi_lib snd_rawmidi iTCO_wdt iTCO_vendor_support snd_hda_codec_hdmi snd_hda_codec_realtek x86_pkg_temp_thermal coretemp kvm microcode arc4 serio_raw iwldvm gspca_zc3xx gspca_main videodev mac80211 media i2c_i801 lpc_ich mfd_core iwlwifi cdc_mbim cfg80211 snd_hda_intel sdhci_pci sdhci snd_hda_codec cdc_acm cdc_ncm usbnet e1000e snd_hwdep snd_seq mei_me snd_seq_device mei snd_pcm cdc_wdm ptp mii pps_core mmc_core snd_page_alloc snd_timer shpchp thinkpad_acpi snd soundcore rfkill wmi mperf uinput dm_crypt crc32_pclmul crc32c_intel ghash_clmulni_intel i915 i2c_algo_bit drm_kms_helper drm video i2c_core
CPU: 0 PID: 1560 Comm: X Not tainted 3.11.7-200.fc19.x86_64 #1
Hardware name: LENOVO 2324JK2/2324JK2, BIOS G2ET82WW (2.02 ) 09/11/2012
 0000000000000009 ffff8803fe9db898 ffffffff8164777b ffff8803fe9db8e0
 ffff8803fe9db8d0 ffffffff8106715d ffff8804081ce6d0 0000000000000001
 ffff880405fc5800 ffff8804081ce000 ffff880405fc5c78 ffff8803fe9db930
Call Trace:
 [<ffffffff8164777b>] dump_stack+0x45/0x56
 [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff810671cc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffffa00add4f>] check_crtc_state+0x5af/0x9f0 [i915]
 [<ffffffffa00b8f73>] intel_modeset_check_state+0x2c3/0x7a0 [i915]
 [<ffffffffa00b94c5>] intel_set_mode+0x25/0x30 [i915]
 [<ffffffffa00b9d12>] intel_crtc_set_config+0x742/0x920 [i915]
 [<ffffffffa002ca6d>] drm_mode_set_config_internal+0x5d/0xe0 [drm]
 [<ffffffffa002f447>] drm_mode_setcrtc+0xf7/0x650 [drm]
 [<ffffffff8164a992>] ? mutex_lock+0x12/0x2f
 [<ffffffffa0020142>] drm_ioctl+0x532/0x660 [drm]
 [<ffffffff811b9e9d>] do_vfs_ioctl+0x2dd/0x4b0
 [<ffffffff811ba0f1>] SyS_ioctl+0x81/0xa0
 [<ffffffff81656999>] system_call_fastpath+0x16/0x1b
Comment 1 klaus 2013-11-10 13:32:15 EST
Created attachment 822132 [details]
File: dmesg
Comment 2 Joe Zeff 2013-11-10 15:03:47 EST
Description of problem:
Judging by the time, it happened while I was booting the computer; aside from that, I've no idea how/why it happened.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.9
cmdline:        BOOT_IMAGE=/vmlinuz-3.11.4-201.fc19.i686.PAE root=UUID=e211a9d3-2592-4a94-8424-a9251dd7c58c ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.11.4-201.fc19.i686.PAE
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 91 at drivers/gpu/drm/i915/intel_display.c:8296 check_crtc_state+0x590/0xb30 [i915]()
pipe state doesn't match!
Modules linked in: ums_realtek usb_storage i915(+) i2c_algo_bit drm_kms_helper drm i2c_core video
CPU: 1 PID: 91 Comm: systemd-udevd Not tainted 3.11.4-201.fc19.i686.PAE #1
Hardware name: TOSHIBA Satellite L305/Portable PC, BIOS 1.80 03/20/2009
 00000000 00000000 f6e8156c c0992ef8 f6e815ac f6e8159c c04549de f862eaae
 f6e815c8 0000005b f8626578 00002068 f85e0970 f85e0970 f6d2d64c f6d2d000
 0000000a f6e815b4 c0454a33 00000009 f6e815ac f862eaae f6e815c8 f6e8181c
Call Trace:
 [<c0992ef8>] dump_stack+0x41/0x52
 [<c04549de>] warn_slowpath_common+0x7e/0xa0
 [<f85e0970>] ? check_crtc_state+0x590/0xb30 [i915]
 [<f85e0970>] ? check_crtc_state+0x590/0xb30 [i915]
 [<c0454a33>] warn_slowpath_fmt+0x33/0x40
 [<f85e0970>] check_crtc_state+0x590/0xb30 [i915]
 [<f85eaed3>] intel_modeset_check_state+0x2a3/0x760 [i915]
 [<f85eb420>] intel_set_mode+0x30/0x40 [i915]
 [<f85ebc1c>] intel_crtc_set_config+0x6fc/0x8f0 [i915]
 [<f81d4f2b>] drm_mode_set_config_internal+0x4b/0xc0 [drm]
 [<f7e6d2dd>] drm_fb_helper_set_par+0x4d/0xb0 [drm_kms_helper]
 [<c06df842>] fbcon_init+0x482/0x4d0
 [<c074a45e>] visual_init+0x9e/0x100
 [<c074c80a>] do_bind_con_driver+0x10a/0x2c0
 [<c05bdffb>] ? sysfs_create_file+0x2b/0x30
 [<c074cecd>] do_take_over_console+0xfd/0x190
 [<c06db30f>] do_fbcon_takeover+0x5f/0xc0
 [<c06e026f>] fbcon_event_notify+0x59f/0x6b0
 [<c05bdfac>] ? sysfs_add_file_mode+0x7c/0xa0
 [<c099c711>] notifier_call_chain+0x41/0x60
 [<c0476bdb>] __blocking_notifier_call_chain+0x3b/0x60
 [<c0476c1f>] blocking_notifier_call_chain+0x1f/0x30
 [<c06d0a86>] fb_notifier_call_chain+0x16/0x20
 [<c06d2493>] register_framebuffer+0x1b3/0x2e0
 [<f7e6cfd4>] drm_fb_helper_initial_config+0x2d4/0x480 [drm_kms_helper]
 [<f85bb27f>] ? i915_write32+0x9f/0x150 [i915]
 [<f85bad32>] ? i915_read32+0x52/0x130 [i915]
 [<f860aafe>] intel_fbdev_initial_config+0x1e/0x20 [i915]
 [<f85bedaa>] i915_driver_load+0xd2a/0xd60 [i915]
 [<f85bbe00>] ? i915_switcheroo_set_state+0xa0/0xa0 [i915]
 [<f81d12c3>] drm_get_pci_dev+0x133/0x240 [drm]
 [<f85ba69b>] i915_pci_probe+0x2b/0x60 [i915]
 [<c06b7f3f>] pci_device_probe+0x6f/0xb0
 [<c0776b29>] driver_probe_device+0x79/0x360
 [<c06b7e8e>] ? pci_match_device+0x9e/0xb0
 [<c0776ec1>] __driver_attach+0x71/0x80
 [<c0776e50>] ? __device_attach+0x40/0x40
 [<c0774f67>] bus_for_each_dev+0x47/0x80
 [<c077662e>] driver_attach+0x1e/0x20
 [<c0776e50>] ? __device_attach+0x40/0x40
 [<c0776267>] bus_add_driver+0x1c7/0x280
 [<c06b7b30>] ? pci_pm_suspend+0x120/0x120
 [<c06b7b30>] ? pci_pm_suspend+0x120/0x120
 [<c077747a>] driver_register+0x6a/0x130
 [<c0448910>] ? __set_pmd_pte+0xa0/0xa0
 [<c06b6e42>] __pci_register_driver+0x32/0x40
 [<f81d14c5>] drm_pci_init+0xf5/0x100 [drm]
 [<f8181000>] ? 0xf8180fff
 [<f818105e>] i915_init+0x5e/0x60 [i915]
 [<c04020ca>] do_one_initcall+0xca/0x190
 [<c04df338>] ? tracepoint_module_notify+0x118/0x160
 [<f8181000>] ? 0xf8180fff
 [<c0449eef>] ? set_memory_nx+0x5f/0x70
 [<c09906f4>] ? set_section_ro_nx+0x54/0x59
 [<c04b250a>] load_module+0x1c1a/0x2320
 [<c04b2d75>] SyS_finit_module+0x75/0xc0
 [<c0527ecb>] ? vm_mmap_pgoff+0x7b/0xa0
 [<c09a00cd>] sysenter_do_call+0x12/0x28
Comment 3 Joe Zeff 2013-11-10 15:23:49 EST
Description of problem:
This happened on my laptop (as the earlier crash did) when rebooting after a kernel update.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.9
cmdline:        BOOT_IMAGE=/vmlinuz-3.11.7-200.fc19.i686.PAE root=UUID=e211a9d3-2592-4a94-8424-a9251dd7c58c ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.11.7-200.fc19.i686.PAE
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 95 at drivers/gpu/drm/i915/intel_display.c:8329 check_crtc_state+0x5b0/0xb70 [i915]()
pipe state doesn't match!
Modules linked in: i915(+) ums_realtek i2c_algo_bit usb_storage drm_kms_helper drm i2c_core video
CPU: 1 PID: 95 Comm: systemd-udevd Not tainted 3.11.7-200.fc19.i686.PAE #1
Hardware name: TOSHIBA Satellite L305/Portable PC, BIOS 1.80 03/20/2009
 00000000 00000000 f6e8956c c0992acd f6e895ac f6e8959c c045499e f862edc2
 f6e895c8 0000005f f8626818 00002089 f85e0a60 f85e0a60 f481064c f4810000
 00000004 f6e895b4 c04549f3 00000009 f6e895ac f862edc2 f6e895c8 f6e8981c
Call Trace:
 [<c0992acd>] dump_stack+0x41/0x52
 [<c045499e>] warn_slowpath_common+0x7e/0xa0
 [<f85e0a60>] ? check_crtc_state+0x5b0/0xb70 [i915]
 [<f85e0a60>] ? check_crtc_state+0x5b0/0xb70 [i915]
 [<c04549f3>] warn_slowpath_fmt+0x33/0x40
 [<f85e0a60>] check_crtc_state+0x5b0/0xb70 [i915]
 [<f85eafc3>] intel_modeset_check_state+0x2a3/0x760 [i915]
 [<f85eb4f0>] intel_set_mode+0x30/0x40 [i915]
 [<f85ebcec>] intel_crtc_set_config+0x6fc/0x8f0 [i915]
 [<f81d4f1b>] drm_mode_set_config_internal+0x4b/0xc0 [drm]
 [<f7e6d2dd>] drm_fb_helper_set_par+0x4d/0xb0 [drm_kms_helper]
 [<c06df2a2>] fbcon_init+0x482/0x4d0
 [<c0749e6e>] visual_init+0x9e/0x100
 [<c074c21a>] do_bind_con_driver+0x10a/0x2c0
 [<c05bdddb>] ? sysfs_create_file+0x2b/0x30
 [<c074c8dd>] do_take_over_console+0xfd/0x190
 [<c06dad6f>] do_fbcon_takeover+0x5f/0xc0
 [<c06dfccf>] fbcon_event_notify+0x59f/0x6b0
 [<c05bdd8c>] ? sysfs_add_file_mode+0x7c/0xa0
 [<c099c311>] notifier_call_chain+0x41/0x60
 [<c0476bbb>] __blocking_notifier_call_chain+0x3b/0x60
 [<c0476bff>] blocking_notifier_call_chain+0x1f/0x30
 [<c06d05a6>] fb_notifier_call_chain+0x16/0x20
 [<c06d1fa3>] register_framebuffer+0x1b3/0x2e0
 [<f7e6cfd4>] drm_fb_helper_initial_config+0x2d4/0x480 [drm_kms_helper]
 [<f85bb27f>] ? i915_write32+0x9f/0x150 [i915]
 [<f85bad32>] ? i915_read32+0x52/0x130 [i915]
 [<f860acde>] intel_fbdev_initial_config+0x1e/0x20 [i915]
 [<f85bedb2>] i915_driver_load+0xd32/0xd60 [i915]
 [<f85bbe00>] ? i915_switcheroo_set_state+0xa0/0xa0 [i915]
 [<f81d12b3>] drm_get_pci_dev+0x133/0x240 [drm]
 [<f85ba69b>] i915_pci_probe+0x2b/0x60 [i915]
 [<c06b7b7f>] pci_device_probe+0x6f/0xb0
 [<c0776679>] driver_probe_device+0x79/0x360
 [<c06b7ace>] ? pci_match_device+0x9e/0xb0
 [<c0776a11>] __driver_attach+0x71/0x80
 [<c07769a0>] ? __device_attach+0x40/0x40
 [<c0774ab7>] bus_for_each_dev+0x47/0x80
 [<c077617e>] driver_attach+0x1e/0x20
 [<c07769a0>] ? __device_attach+0x40/0x40
 [<c0775db7>] bus_add_driver+0x1c7/0x280
 [<c06b7770>] ? pci_pm_suspend+0x120/0x120
 [<c06b7770>] ? pci_pm_suspend+0x120/0x120
 [<c0776fca>] driver_register+0x6a/0x130
 [<c04488d0>] ? __set_pmd_pte+0xa0/0xa0
 [<c06b6a82>] __pci_register_driver+0x32/0x40
 [<f81d14b5>] drm_pci_init+0xf5/0x100 [drm]
 [<f8181000>] ? 0xf8180fff
 [<f818105e>] i915_init+0x5e/0x60 [i915]
 [<c04020ca>] do_one_initcall+0xca/0x190
 [<c04df228>] ? tracepoint_module_notify+0x118/0x160
 [<f8181000>] ? 0xf8180fff
 [<c0449eaf>] ? set_memory_nx+0x5f/0x70
 [<c09902e4>] ? set_section_ro_nx+0x54/0x59
 [<c04b241a>] load_module+0x1c1a/0x2320
 [<c04b2c85>] SyS_finit_module+0x75/0xc0
 [<c0527dcb>] ? vm_mmap_pgoff+0x7b/0xa0
 [<c099fccd>] sysenter_do_call+0x12/0x28
Comment 4 Joe Zeff 2013-11-28 19:52:12 EST
Just to confirm, this is still happening at every boot.  I've just rebooted after an update to kernel 3.11.9-200.fc19.i686.PAE if that helps.  And, only on my laptop; my desktop boots without any difficulty, and if there weren't a notice from abrt, I'd not know that there's anything wrong, because once the laptop boots it works fine.
Comment 5 Adam Jackson 2014-11-18 15:18:51 EST

*** This bug has been marked as a duplicate of bug 1027037 ***

Note You need to log in before you can comment on or make changes to this bug.